Opened 13 years ago

Closed 12 years ago

#3408 closed defect (invalid)

Parser not found for Codec Id: 94212 and 94211!

Reported by: anonymous Owned by: Isaac Richards
Priority: major Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

With last SVN when I transcode a recording I get this error:

stream: start_time: 13591.640 duration: 1195.939 bitrate=7754 kb/s 2007-05-04 17:57:50.288 AFD: Opened codec 0x1270cba0, id(MPEG2VIDEO) type(Video) 2007-05-04 17:57:50.288 AFD: Opened codec 0x9d95320, id(MP3) type(Audio) 2007-05-04 17:57:50.288 AFD: Opened codec 0x9d95670, id(MP3) type(Audio) [mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94211 ! [mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 ! [mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 ! [mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 ! [mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 ! [mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 ! [mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 ! [mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 ! [mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 ! [mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 ! 0: start_time: 1223.271 duration: 107.611 1: start_time: 1223.248 duration: 107.618 2: start_time: 1223.259 duration: 107.590 3: start_time: 1223.251 duration: 107.613 4: start_time: 1223.248 duration: 107.635 5: start_time: 1223.248 duration: 107.635 6: start_time: 1223.248 duration: 107.635 7: start_time: 1223.248 duration: 107.635 8: start_time: 1223.248 duration: 107.635 9: start_time: 1223.248 duration: 107.635 10: start_time: 1223.248 duration: 107.635 11: start_time: 1223.248 duration: 107.635 12: start_time: 1223.248 duration: 107.635

Change History (6)

comment:1 Changed 13 years ago by anonymous

stream: start_time: 13591.640 duration: 1195.939 bitrate=7754 kb/s
2007-05-04 17:57:50.288 AFD: Opened codec 0x1270cba0, id(MPEG2VIDEO) type(Video)
2007-05-04 17:57:50.288 AFD: Opened codec 0x9d95320, id(MP3) type(Audio)
2007-05-04 17:57:50.288 AFD: Opened codec 0x9d95670, id(MP3) type(Audio)
[mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94211 !
[mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 !
[mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 !
[mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 !
[mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 !
[mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 !
[mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 !
[mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 !
[mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 !
[mpegts @ 0xb75fb6b0]Parser not found for Codec Id: 94212 !
0: start_time: 1223.271 duration: 107.611
1: start_time: 1223.248 duration: 107.618
2: start_time: 1223.259 duration: 107.590
3: start_time: 1223.251 duration: 107.613
4: start_time: 1223.248 duration: 107.635
5: start_time: 1223.248 duration: 107.635
6: start_time: 1223.248 duration: 107.635
7: start_time: 1223.248 duration: 107.635
8: start_time: 1223.248 duration: 107.635
9: start_time: 1223.248 duration: 107.635
10: start_time: 1223.248 duration: 107.635
11: start_time: 1223.248 duration: 107.635
12: start_time: 1223.248 duration: 107.635

comment:2 Changed 13 years ago by stuartm

Resolution: invalid
Status: newclosed

The codec parser error isn't relevant to any transcoding failure you are experiencing. We need logs showing the point where the transcoder errors.

comment:3 Changed 12 years ago by anonymous

Resolution: invalid
Status: closedreopened

after googling around, it seems a few people suffer from this problem with UK DVB-T recordings, myself included.

Could you explain how to get an appropriate log/error report for you.

Thanks Mark

comment:4 Changed 12 years ago by stuartm

Resolution: invalid
Status: reopenedclosed

First we need to know what is going wrong? Does transcoding not complete? Is the transcoded file somehow damaged?

Second if transcoding fails there is normally an error in the log, we need that error. If necessary, run "mythtranscode -v most" to increase the log verbosity. Attach that log to the ticket.

comment:5 Changed 12 years ago by mark.pappin@…

Resolution: invalid
Status: closedreopened

It doesn't occur just when transcoding - watching live TV (.au DVB-T, SBS Queensland, in case it's relevant; using out-of-the-box Mythbuntu 7.10 with all updates applied) this afternoon I got ...

[mpegts @ 0xb74838b0]Parser not found for Codec Id: 94211 ! 2007-12-08 17:14:01.049 AFD: Opened codec 0x88085e0, id(MPEG2VIDEO) type(Video) 2007-12-08 17:14:01.049 AFD: Opened codec 0x9b544d0, id(MP3) type(Audio) 2007-12-08 17:14:01.050 AFD: Opened codec 0x9c5d710, id(AC3) type(Audio) 2007-12-08 17:14:01.051 AFD: Opened codec 0x8808b90, id(MPEG2VIDEO) type(Video) 2007-12-08 17:14:01.310 DPMS Deactivated [mpegts @ 0xb74838b0]Parser not found for Codec Id: 94212 ! [mpegts @ 0xb74838b0]Parser not found for Codec Id: 94211 ! 2007-12-08 17:14:13.503 AFD: Opened codec 0x88085e0, id(MPEG2VIDEO) type(Video) 2007-12-08 17:14:13.503 AFD: Opened codec 0x9b544d0, id(MP3) type(Audio) 2007-12-08 17:14:23.968 Using protocol version 31 2007-12-08 17:14:30.683 RingBuf?(/var/lib/mythtv/recordings/1090_20071208171424.mpg): Invalid file (fd -1) when opening '/var/lib/mythtv/recordings/1090_20071208171424.mpg'. [mpegts @ 0xb74838b0]Parser not found for Codec Id: 94211 ! Segmentation fault (core dumped)

Since I started using this freshly-installed system, every recorded program from this channel has (when I try to watch it) given me a "file missing" error. I have auto-transcoding turned on so I may be seeing the same symptom as anonymous Mark, but there was no transcoding involved today and the same message appeared. And the file disappeared from under the nose of the backend.

stuartm, if you're going to keep closing this ticket, please make it clear _why_. The title says "Parser not found".

  • if the Codec Ids are invalid (thus the station is transmitting bogus data), say so.
  • if the Codec Ids are valid but we just don't have parsers for them and a decision has been made to not support them, say so.
  • if the transcoder and frontend are intended to crash and burn when a parser can't be found, say so.
  • if it's expected behaviour for the ringbuffer file to disappear underneath the backend's nose, say so.

Otherwise, leave the ticket open until it's fixed.

Another Mark.

comment:6 Changed 12 years ago by Janne Grunau

Resolution: invalid
Status: reopenedclosed

The parser not found messages are probably unrelated to the problem you are seeing. The ticket was closed as invalid since the original poster failed to describe the problem he is seeing.

Your segmentation fault and the file not found error are real problems but unrelated to this ticket. You're not using the same version as the original poster and he claimed that it started 6 months ago. Please open a new ticket and attach a backtrace for the segmentation fault (see http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2 how to do so, you probably need to install the debug packages for mythtv).

Note: See TracTickets for help on using tickets.