Opened 13 years ago

Closed 11 years ago

#3410 closed defect (invalid)

EPG video preview leaves chaff when video aspect ratio changes

Reported by: danielk Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

I noticed this while working on [13405]. I've traced it down to VideoOutputXv::DrawUnusedRects?(), but no further.

Attached is a patch which fixes the random black rectangle problem by just not drawing the rectangles in the EPG, but may leave some chaff on the screen.

Attachments (1)

3410-quick-fix.patch (547 bytes) - added by danielk 13 years ago.
Work around until I can look at this problem more closely

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by danielk

Attachment: 3410-quick-fix.patch added

Work around until I can look at this problem more closely

comment:1 Changed 13 years ago by danielk

(In [13435]) Refs #3410. Works around a bug where the VideoOutputXV::DrawUnusedRects?() would draw in the wrong place in the EPG.

XFillRectangle is being called with the correct coordinates, and this works when DrawUnusedRects?() is the first time in the EPG, but when it is drawn when the EPG is in the wrong part of its event loop it gets offset. DrawUnusedRects?() doesn't really do anything unless the aspect ratio or resolution of the video changes, and then it just leaves a little chaff.

comment:2 Changed 13 years ago by danielk

Milestone: 0.21unknown
Severity: mediumlow
Summary: Video Preview draws random black rectange in EPGEPG video preview leaves chaff when video aspect ratio changes

comment:3 Changed 13 years ago by danielk

(In [13617]) Fixes #3466. Refs #3410. This fixes preview for XVideo chromkeyed video in the program guide video preview caused by the fix for #3410, and fixes a longstanding bug that caused the video to 'flash' with other video renderers in the preview.

The fix for the DrawUnusedRects?() being drawn in the wrong place in #3410 disabled the drawing of the chromakey color causing chromakeyed video to be hidden from view. This patch instead makes the guidegrid call DrawUnusedRects?() when it is thread safe to do so.

It turned out that DrawUnusedRects?() was also causing flashing whenever there was a prebuffering pause during playback, so this fixes that problem as well.

comment:4 Changed 11 years ago by danielk

Resolution: invalid
Status: newclosed

The display code for the EPG video preview has changed since this ticket was opened. It now has a different problem, the background gets repainted over the foreground. But in any case this ticket is no longer pertinent.

Note: See TracTickets for help on using tickets.