Opened 13 years ago

Closed 12 years ago

#3412 closed defect (duplicate)

Mythbackend should not exit on errors

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

From my Mythbackend log:

2007-05-05 01:30:08.650 Finished recording : channel 3507 2007-05-05 01:30:31.708 MainServer?: HandleRemoteEncoder?(cmd GET_STATE) Unknown encoder: 5, exiting

And poof, there goes the backend.

I guess this was caused by "2007-05-05 01:26:16.608 mythbackend: Problem with capture cards: Card 5failed init" but that's a separate problem. I feel the backend should not exit on such things, as this breaks all scheduled/ongoing recordings and livetv viewing from other frontends until it is restarted. Returning an error message to the requesting frontend and continuing business as usual would be a far better solution I think?

I guess I should file a feature request for authentication on the protocol, as with this exiting and crashing (there's also segfaults, as I discovered while trying to debug the protocol) anyone on your network can kill the backend and sabotage everything. :(

Change History (1)

comment:1 Changed 12 years ago by stuartm

Resolution: duplicate
Status: newclosed

Duplicate of #3022

Note: See TracTickets for help on using tickets.