Modify

Opened 11 years ago

Closed 11 years ago

#3432 closed defect (worksforme)

Restarting backend while mythtranscode is running violates job queue rules

Reported by: kkuphal Owned by: cpinkham
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Today I had a mythtranscode job running to convert HD to MPEG-4 and restarted mythbackend during the process. The original mythtranscode job continued to run and a second mythtranscode job was started when the backend came up. My system is configured for only one job running at a time.

I believe this is a bug as the backend should either stop the original transcode and restart it, realize a transcode is running and monitor it, or abort the transcode and move onto the next job. It is also unclear weather the original running transcode will complete successfully or now fail after finishing.

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by cpinkham

  • Owner changed from ijr to cpinkham

comment:2 Changed 11 years ago by cpinkham

  • Resolution set to worksforme
  • Status changed from new to closed

I am unable to reproduce this, I start and stop mythbackend all the time on my development box with jobs running and haven't run into this issue. All child processes of the JobQueue? should die when the parent mythbackend dies. If this happens again, please get some debug info like a ps output or whatever else you can think of that might help debug the issue.

Add Comment

Modify Ticket

Action
as closed The owner will remain cpinkham.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.