Opened 13 years ago

Closed 12 years ago

#3451 closed defect (worksforme)

Mythgame 100% cpu

Reported by: anonymous Owned by: greg
Priority: minor Milestone: unknown
Component: mythgame Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I'm having a problem with Mythgame (possibly Mythtv) and executing emulators. I can browse to a rom, execute it and the appropriate emulator will start however CPU usage on the emulator process will immediately jump to 100% and the emulator will run extremely slowly. This is occuring for emulators zsnes, xmame and mupen64. I would guess the same problem would occurs with other emulators however I've not tried further. Each of these emulators will run perfectly if Mythtv is not running. I'm not sure the problem is with mythGame itself however, as if I run mythfrontend, then execute an emulator from outside of it (ie from a separate prompt) the same problem occurs. Interestingly, if the emulator is already running when Mythtv is started it is the mythfrontend process that goes to 100% cpu.

If I run mythfrontend with -v all I see the following line just before zsnes (Or other emulator) loads: "MythThemedDialog?.o: something is requesting a screen update of zero size. A widget probably has not done a calculateScreeArea(). Will redraw the whole screen (inefficient!)."

and I'm wondering whether something like this might be causing a problem.

Environment 2.8 P4 (Hyperthreading disabled) MythGame? 0.20a (although the same problem occurs with the svn version too) Ubuntu Feisty Nvidia 6200 (Driver version 9629)

The fact that this is occuring for multiple emulators makes me think that this is a bug with Myth rather than the emulators themselves.

Change History (3)

comment:1 Changed 12 years ago by greg

Owner: changed from Isaac Richards to greg

comment:2 Changed 12 years ago by paulh

Component: mythtvmythgame

comment:3 Changed 12 years ago by greg

Resolution: worksforme
Status: newclosed

So far noone has reproduced this or provided any real troubleshooting/diagnostic info.

If someone can please reopen the ticket and add in details.

Note: See TracTickets for help on using tickets.