Opened 12 years ago

Closed 12 years ago

#3494 closed defect (duplicate)

Can't view a valid QAM channel unless tuning to the other channel on the same freq first

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.21
Component: dvb Version: head
Severity: medium Keywords: dvb, qam
Cc: Ticket locked: no

Description

I am using QAM and have two channels on the same freq. (multiplex) Here is their channel.conf values.

KVUE1:573000000:QAM_256:64:65:42 KEYE1:573000000:QAM_256:66:67:41

When watching live TV I can not view KEYE1 with out first tuning to KVUE1. If I don't this results in a black screen and mythtv telling me it can't get a signal. If I then switch to another channel say like...

KXAN1:585000000:QAM_256:67:68:2

and then try to go back to KEYE1 I get the blank screen again unless I again go to KVUE1 right before.

If I have recording on KEYE1 it just puts an empty file on my recordings screen.

I did notice in the backend logs that I get a "DTVSM(0): Ignoring encrypted program" when the problem occurs but that doesn't show up if i go to KVUE1 first.

The problem is with mythtv because I used azap to tune to KEYE1 and was able to view it with mplayer without going to KVUE1 first.

I am using gentoo and the mythtv-0.20.1_p13344 ebuild and through trial and error figured out the bug entered mythtv sometime after mythtv 0.20 because the ebuild 0.20_p13110 worked.

I know the devs don't like the ebuild version numbers so here are actual version info.

The version that works correctly:

mythbackend ~ # mythbackend --version Library API version: 0.20.20060828-3 Source code version: exported Options compiled in:

linux release using_v4l using_oss using_alsa using_ivtv using_lirc using_dvb using_x11 using_xv using_xrandr using_opengl_vsync using_opengl using_frontend using_backend using_bindings_perl

The version that is broken:

mythbackend ~ # mythbackend --version Library API version: 0.20.20060828-4 Source code version: exported Options compiled in:

linux debug using_v4l using_oss using_alsa using_ivtv using_lirc using_dvb using_x11 using_xv using_xrandr using_opengl_vsync using_opengl using_frontend using_backend using_bindings_perl

The card I am using is a AirStar?-HD5000-PCI

Here is the modinfo on b2c2_flexcop

filename: /lib/modules/2.6.19-gentoo-r5/kernel/drivers/media/dvb/b2c2/b2c2-flexcop.ko author: Patrick Boettcher <patrick.boettcher@… description: B2C2 FlexcopII/II(b)/III digital TV receiver chip license: GPL vermagic: 2.6.19-gentoo-r5 SMP preempt mod_unload PENTIUM4 depends: dvb-pll,stv0299,lgdt330x,i2c-core,nxt200x,stv0297,bcm3510,firmware_class,mt312,mt352

parm: debug:set debug level (1=info,2=tuner,4=i2c,8=ts,16=sram,32=reg (able)). (debugging is not enabled) (int)

Attached to this ticket is a gdb and mythbackend log of the problem happening. I first went to KEYE1 (1531) to show I can't view it. I then go to KVUE1 (1511) and then back to KEYE1 (1531) to show I am able to view it this time.

Change History (2)

comment:1 Changed 12 years ago by evan.alter@…

Please ignore this ticket. I messed up and forgot to add my email address. The actual ticket is 3495.

comment:2 Changed 12 years ago by danielk

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.