Opened 13 years ago

Closed 13 years ago

#3520 closed defect (fixed)

mtd assumes incorrect frame rate code

Reported by: anonymous Owned by: Anduin Withers
Priority: minor Milestone: 0.21
Component: mythdvd Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Nearly every (transcoded) rip I make of my son's DVDs have incorrect audio/video sync. I have been dealing with this for two years, having my wife adjust the offset with the remote control - onto which I have mapped the sync adjust keys in lirc.

After banging my head against the wall for a weekend, it turns out that the problem is that mtd gives -f0,1 for every encoding even though the frame rate is actually frc 4.

Just removing the -f entirely allows transcode (e.g. tcprobe) to get this right.

I see that dvdinput table defines frc 1 for all NTSC sources. (And 3 for all PAL). This seems to be a hasty generalization.

Many children's DVDs don't seem to fall into these categories. Probably because they come from TV and not film.

Also, I have found many pan/scan cheap kids releases of theatrical (e.g. the Babe/Babe2 double sided DVD) have the same problem.

Summary - mythdvd is making an assumption that is breaking transcode's ability to autodetect and do the right thing...

request - at least give us the option "don't override detected frame rate" a la the option of "use xvid instead of divx"

Change History (2)

comment:1 Changed 13 years ago by Anduin Withers

(In [13536]) References #3520

Adds a new option "Let transcode determine frame rate" (defaults to on) which allows transcode to determine the frame rate. Prior to this patch "coded 24fps" content was expected (for NTSC).

Note: After changing the option you will need to restart mtd.

With thanks to Rod Nayfield for being that final person needed to shame me in to settling on a quick fix.

comment:2 Changed 13 years ago by Anduin Withers

Resolution: fixed
Status: newclosed

(In [13638]) Closes #3520

Merge head [13536] fix.

Original commit message:

Adds a new option "Let transcode determine frame rate" (defaults to on) which allows transcode to determine the frame rate. Prior to this patch "coded 24fps" content was expected (for NTSC).

Note: After changing the option you will need to restart mtd.

With thanks to Rod Nayfield for being that final person needed to shame me in to settling on a quick fix.

Note: See TracTickets for help on using tickets.