Opened 12 years ago

Closed 12 years ago

#3524 closed enhancement (fixed)

extendedslidertext is difficult to use as implemented

Reported by: David Asher <david.asher@…> Owned by: paulh
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When I went to implement a way to get time remaining on the status bar I noticed that extendedslidertext was intended to provide it. Unfortunately, it is defined as the string "(<time> remaining)". This makes it very difficult to use without a monspaced font. My goal was to end up with a string like "<time> of <time> (<time> remaining)". Since the first part would change length for a variable size font, I couldn't figure out a way to place the extendedslidertext so it moved with the slidertext.

This patch makes extendedslidertext be the full string above. It didn't look like any of the themes were using extendedslidertext, so it didn't seem like a problem to redefine its meaning.

Let me know if there is a better way to do this.

Attachments (1)

extdesc.patch (669 bytes) - added by David Asher <david.asher@…> 12 years ago.
patch to make extdesc include desc and remaining time

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by David Asher <david.asher@…>

Attachment: extdesc.patch added

patch to make extdesc include desc and remaining time

comment:1 Changed 12 years ago by paulh

Milestone: unknown0.21
Owner: changed from Isaac Richards to paulh
Version: unknownhead

comment:2 Changed 12 years ago by paulh

Resolution: fixed
Status: newclosed

(In [14726]) Change the format of the text displayed in the OSD for 'extendedstatustext' elements to be like "<time> of <time> (<time> remaining)". No OSD themes in current svn actually use that element as far as I can see.

Patch by David Asher. Closes #3524.

Note: See TracTickets for help on using tickets.