Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3531 closed patch (fixed)

Patch for keybinding overlap in exit dialog

Reported by: anonymous Owned by: stuartm
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I recently upgraded to SVN from 0.20-fixes.

If I'm watching a recording and try to exit I get the "Save this location / Just exit/..." dialog. If I press "UP" on my remote I can cycle through the options, but if I press "DOWN" the dialog disappears and the recording jumps back.

I found this is caused by my having "JUMPRWND" to the "DOWN" button. This is being trapped within tv_play.cpp and exiting the dialog.

The attached patch checks for the overlap of these bindings and fixed the problem for me.

-Bill

Attachments (1)

exitdialog.patch (606 bytes) - added by anonymous 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by anonymous

Attachment: exitdialog.patch added

comment:1 Changed 12 years ago by stuartm

Owner: changed from Isaac Richards to stuartm

comment:2 Changed 12 years ago by stuartm

Resolution: fixed
Status: newclosed

(In [13586]) Ignore the actions JUMPRWND, RWNDSTICKY or SEEKRWND in OSD dialogues if they are bound to the same key as UP or DOWN. This fixes unexpected behaviour when navigating menus.

Patch by Bill.

Closes #3531

comment:3 Changed 12 years ago by stuartm

Milestone: unknown0.21
Version: unknownhead
Note: See TracTickets for help on using tickets.