Opened 13 years ago

Closed 12 years ago

#3536 closed defect (fixed)

Filters in MythMusic do not work

Reported by: anonymous Owned by: stuartm
Priority: minor Milestone: 0.21
Component: mythmusic Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If I am playing a song in MythMusic and I try to filter by Artist/Album/Year?, all tracks disappear except for the first. I have added debugging statements and verified that the SQL query is executing correctly and that the metadata is being retrieved correctly.

Change History (4)

comment:1 Changed 13 years ago by stuartm

Owner: changed from Isaac Richards to stuartm
Version: unknownhead

comment:2 Changed 13 years ago by Daniel Burr

Upon closer inspection, what actually appears to be happening is that the view changes from "All My Playlists/Active? Play Queue" to "All My Music/Artists? (...)/(theme)/Unknown Album". There happens to be only one song in there which is why I thought that every item except for the first was disappearing.

If I navigate back to "All My Playlists/Active? Play Queue" then I can see every song, i.e. not the filtered list.

comment:3 Changed 13 years ago by Daniel Burr

I have attached a fix to this bug in ticket #3550

comment:4 Changed 12 years ago by stuartm

Resolution: fixed
Status: newclosed

(In [13798]) Fixes #3550 and #3536

Applies patch by Daniel Burr to fix issues with the music tree and filters. These problems only appear in "Show entire music tree" mode, so that probably explains why they haven't been spotted before.

Note: See TracTickets for help on using tickets.