Opened 12 years ago

Closed 12 years ago

#3569 closed defect (invalid)

mytharchive fails with python error

Reported by: davemorris@… Owned by: paulh
Priority: minor Milestone: unknown
Component: mytharchive Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi,

I'm using the 0.20svn20070122ubuntu3 package from ubuntu of mytharchive. In my setup I've got a dedicated backend and a dedicated frontend. Since my backend is under powered I wanted to run the archiving on the frontend.

The python error is here.

2007-02-14 18:13:03 mythburn.py (0.1.20060910-1) starting up... 2007-02-14 18:13:03 Obtaining MythTV settings from MySQL database for hostname pacifica 2007-02-14 18:13:04 Obtaining date and time settings from MySQL database for hostname pacifica 2007-02-14 18:13:04 Processing Mythburn job number 1. 2007-02-14 18:13:04 Options - mediatype = 0, doburn = 0, createiso = 1, erasedvdrw = 0 2007-02-14 18:13:04 savefilename = 2007-02-14 18:13:04 Looking for: /usr/share/mythtv/mytharchive/themes/Compact/theme.xml 2007-02-14 18:13:04 Loading font 0, /usr/share/mythtv/FreeSans.ttf size 23 2007-02-14 18:13:04 Loading font 1, /usr/share/mythtv/FreeSans.ttf size 18 2007-02-14 18:13:04 Loading font 2, /usr/share/mythtv/FreeSans.ttf size 16 2007-02-14 18:13:04 wantIntro: 1, wantMainMenu: 1, wantChapterMenu:0, wantDetailsPage: 0 2007-02-14 18:13:04 Final DVD Video format will be pal 2007-02-14 18:13:04 There are 1 files to process 2007-02-14 18:13:04 Pre-processing file '1035_20070213210000.mpg' of type 'recording' 2007-02-14 18:13:04 ------------------------------------------------------------ Traceback (most recent call last):

File "/usr/share/mythtv/mytharchive/scripts/mythburn.py", line 3393, in <module>

processJob(job)

File "/usr/share/mythtv/mytharchive/scripts/mythburn.py", line 3169, in processJob

preProcessFile(node,folder)

File "/usr/share/mythtv/mytharchive/scripts/mythburn.py", line 1045, in preProcessFile

mediafile = os.path.join(recordingpath, file.attributesfilename?.value)

File "posixpath.py", line 62, in join

elif path == or path.endswith('/'):

AttributeError?: 'NoneType?' object has no attribute 'endswith' 2007-02-14 18:13:04 ------------------------------------------------------------

I'm guessing that either

  • mytharchive looks on the localhost for the mythtv database to grab the information about the recordings. However the database is actually on the backend. In which case it should really connect to which ever backend is set in the frontends config files to grab the info.

or

  • the backend database hasn't got permission/a hostname entry for mytharchive to dip into the database

Change History (3)

comment:1 Changed 12 years ago by stuartm

Reporter: changed from anonymous to davemorris@…

comment:2 Changed 12 years ago by DaveMorris <david.morris@…>

ok, I solved the problem, I needed to nfs mount the recordings dir, which I did as /recordings then I needed to update the database

insert into settings (value, data, hostname) VALUES ('RecordFilePrefix?', '/recordings', 'pacifica');

Please close this if its not a bug, but why did I manually need to edit the database?

comment:3 Changed 12 years ago by paulh

Resolution: invalid
Status: newclosed

Currently MythArchive? will only work properly on combined FE/BE machines.

Note: See TracTickets for help on using tickets.