Opened 12 years ago

Closed 12 years ago

#3578 closed patch (fixed)

Better descriptions for XMLTV options, with repeat check.

Reported by: anonymous Owned by: stuartm
Priority: minor Milestone: 0.21
Component: mythfilldatabase Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The TimeOffset? setting is hard to understand. Most people resort to reading the source code, which is also hard to understand.

The --update option to mythfilldatabase doesn't mention what a non-destructive update is.

The --file option doesn't use <offset> and the description is misleading.

The patch also prevents repeating of --file, --dd-file and --xawchannels options.

Attachments (1)

mythtv.patch (5.0 KB) - added by paulx@… 12 years ago.
The patch.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by paulx@…

Attachment: mythtv.patch added

The patch.

comment:1 Changed 12 years ago by stuartm

Component: mythtvmythfilldatabase
Milestone: unknown0.21
Owner: changed from Isaac Richards to stuartm

comment:2 Changed 12 years ago by stuartm

(In [14161]) Refs #3578

Attempts to improve the label and help text for the TimeOffset? setting. The new description describes the intended behaviour and usage of TimeOffset?.

comment:3 Changed 12 years ago by stuartm

Resolution: fixed
Status: newclosed

(In [14162]) Closes #3578

Rest of changes from Paul Andreassen to improve --help output; Prevent multiple --file, --dd-file and --xawchannels arguments.

Note: See TracTickets for help on using tickets.