Opened 13 years ago

Closed 13 years ago

#3594 closed defect (duplicate)

MythWeb shows current year as production year for all upcoming movie listings set to record

Reported by: anonymous Owned by: xris
Priority: minor Milestone: unknown
Component: mythweb Version: 0.20-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Last week I was away from home when I normally do my review of the movies to air over the next two weeks, and so used MythWeb instead of mythfrontend to pick out the ones I want to record. While doing so I noticed on my 0.20.1 setup that MythWeb's program listings incorrectly show 2007 as the production year for all the movies I've selected to record. An example:

Higher Learning (2007, R, *)

When I in mythfrontend deleted the rule to record this movie, its entry in MythWeb changed to

Higher Learning (1995, R, *)

Whether a movie exists in Recorded Programs has no bearing on how the year appears. Thus, right after the following movie

Moonlight and Valentino (2007, R, *)

was recorded, its MythWeb program entry appeared as the above. A few hours later, once the recording rule automatically expired, the movie appeared this way:

Moonlight and Valentino (1995, R, *)

(NB - Despite the two movies I chose as examples, the bug affects all movies with recording rules, regardless of the correct year of production, MPAA rating, or number of stars.)

Having heavily used MythTV and MythWeb for a year and a half I am certain I'd have noticed a bug like this had it existed much earlier, so believe it was introduced relatively recently.

Change History (2)

comment:1 Changed 13 years ago by ylee@…

Adding myself to the CC list as Trac (yet again) ate my address during the submit process despite my doubly making sure it was there.

comment:2 Changed 13 years ago by stuartm

Resolution: duplicate
Status: newclosed

Duplicate of #2456

Note: See TracTickets for help on using tickets.