Opened 13 years ago

Closed 13 years ago

#3606 closed patch (fixed)

Mutex destroy failure in network control

Reported by: sphery <mtdean@…> Owned by: Isaac Richards
Priority: trivial Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

[13516] to network control from the patch in #3509 results in the error "Mutex destroy failure: Device or resource busy" when shutting down mythfrontend. After speaking to Russell in IRC, he said he has a fix in mind and will provide a patch within a couple of days (once he gets time).

The bug is not high priority as it only occurs on shutdown, only affects mythfrontend, and does not cause any problems. I'm creating this ticket so anyone who notices and is concerned about the message will know what's going on.

Attachments (1)

networkcontrol-3606.diff.txt (1.6 KB) - added by Russell Bryant <russell@…> 13 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 13 years ago by Russell Bryant <russell@…>

That message is almost certainly caused by trying to destroy a mutex with it still locked. The fix will probably be pretty easy. I have a guest in town until tomorrow evening and will be happy to fix it then if nobody else has done it yet.

Changed 13 years ago by Russell Bryant <russell@…>

comment:2 Changed 13 years ago by Russell Bryant <russell@…>

This patch should fix the problem reported here. I also added some code to make extra sure that the networkcontrol command thread doesn't block on shutdown.

comment:3 Changed 13 years ago by Anduin Withers

Type: defectpatch

comment:4 Changed 13 years ago by cpinkham

Resolution: fixed
Status: newclosed

(In [13666]) Fix a "mutex destroy failure" error that was created by [13516].

Closes #3606 using patch by Russell Bryant.

Note: See TracTickets for help on using tickets.