Opened 12 years ago

Closed 12 years ago

#3608 closed defect (fixed)

Latest ffmpeg sync causes decoded AC3 audio to sound like it is going through a table fan.

Reported by: anonymous Owned by: Janne Grunau
Priority: major Milestone: 0.21
Component: mythtv Version: head
Severity: high Keywords:
Cc: Ticket locked: no

Description

I just compiled the latest svn from the trunk and now my decoded AC3 audio sounds like it is going through a table fan, or perhaps an old vhs.
I believe that revision 13655 is the cause because that is the only mention of the AC3 decoder that I know of.

Attachments (2)

ac3_final.diff.bz2 (18.4 KB) - added by Janne Grunau 12 years ago.
updates the ac3 patch to the final version from 2007-05-07
ac3_final_13758.diff.bz2 (17.3 KB) - added by Janne Grunau 12 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by Mark Spieth

build without ac3_decoder and with liba52bin fixes this. this is a change from the previous ffmpeg which disabled ac3dec and used liba52 only.

changes to configure are --enable-liba52bin --disable-decoder=ac3 --enable-decoder=liba52

liba52 is then an external dependency

This was mentioned in aprevious email my me.

comment:2 Changed 12 years ago by Janne Grunau

Milestone: unknown0.21
Owner: changed from Isaac Richards to Janne Grunau
Priority: minormajor
Severity: mediumhigh
Version: unknownhead

I hear only occasionally short distorted passages. It is (at least with my recordings) not very noticable. I first thought the input was overmodulated.

Please provide an example, audio only is enough. I'll contact the ffmpeg dev and look if a never version of the patch (and a minor ffmpeg resync) helps.

comment:3 Changed 12 years ago by darkstarsword@…

I believe that I am suffering this effect on 1 stream I receive (ABC TV Canberra). Interestingly I don't observe it on any other stream, not even ABC TV, which has the same content and is on the same multiplex. I have uploaded a 30 second sample file (24MiB) from ABC TV Canberra here:

http://www.megaupload.com/?d=INKM9DIV

Changed 12 years ago by Janne Grunau

Attachment: ac3_final.diff.bz2 added

updates the ac3 patch to the final version from 2007-05-07

comment:4 in reply to:  3 Changed 12 years ago by Janne Grunau

Replying to darkstarsword@gmail.com:

I have uploaded a 30 second sample file (24MiB) from ABC TV Canberra here:

http://www.megaupload.com/?d=INKM9DIV

I can't reproduce the audio distortions. I don't hear a difference.

Can you please try if the attached patch fixes the audio decoding? I doubt it but it's worth a try.

If it doesn't help please reply with system details and configure options and output.

Changed 12 years ago by Janne Grunau

Attachment: ac3_final_13758.diff.bz2 added

comment:5 Changed 12 years ago by Janne Grunau

I uploaded accidentally an old and unclean patch. Please test only with http://svn.mythtv.org/trac/attachment/ticket/3608/ac3_final_13758.diff.bz2.

comment:6 Changed 12 years ago by Janne Grunau

Resolution: fixed
Status: newclosed

(In [13765]) Fixes #3608. Updates ffmpeg's internal ac3 decoder

This updates the ac3 decoder in our libavcodec copy to the final patch posted on 2007-05-07 by Justin Ruggles pulls also ffmpeg revision 8816 in, since it's need by the patch. Fixes the Audio distortion reported in #3608.

Refs #3634. crashes on x86_32 with debug and release builds

Note: See TracTickets for help on using tickets.