Opened 12 years ago

Closed 12 years ago

#3612 closed defect (duplicate)

One ATSC channel (ABC) is not recording the audio or audio track does not play

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: unknown
Component: dvb Version: head
Severity: medium Keywords: psip audio stream problem
Cc: Ticket locked: no

Description

Library API version : 0.20.20070327-1 Source code version : 13582M Network Protocol Version: 34 Options compiled in:

linux release using_v4l using_arts using_ivtv using_dbox2 using_hdhr using_iptv using_live using_dvb using_x11 using_xv using_xrandr using_frontend using_backend using_bindings_perl

I have been trying to trouble-shoot this problem for at least a month and Daniel K. has been trying to help out. It only started in May on my ABC channel. Everything appears to record correctly but I get no audio on playback. I also verified that mplayer and mythtranscode have problems with the audio track also. Mythbackend shows it is recording stream#0 mpeg2 and stream#1 aac audio. I can view this channel ok on my OTA turner and can also playback a file that I 'cat' right from the dvb device. Using an Air2PC tuner. Have tried different cards. All channels work but this one. Seems to be related to the writing of the streams from the backend since I can play a file recorded directly from the device. I have attached a zip with four log files.

mythnoaudio.log is the backend log of a 5 minute recording of channel 4-1 with mythbackend -v channel,record,siparser. I am also using patch #3409 per Daniels suggestion. It shows the PIDS being parsed and that if finds both the mpeg2 and aac audio streams.

mythtranscode_bad.log shows mythtranscode's error on the same file.

mplayernoaudio.log show mplayer trying to find the appropriate streams from the recorded file and how it only finds the video stream. Audio stream is not found.

ffmpeg_tomp3_good.log is just ffmpeg striping video and saving audio to an mp3 on a good file for comparison.

ffmpeg_tomp3_bad.log is just ffmpeg striping video and saving audio to an mp3 on the bad recording. Cannot parse the audio stream.

Attachments (1)

audio_stream_problem.zip (11.6 KB) - added by anonymous 12 years ago.

Download all attachments as: .zip

Change History (2)

Changed 12 years ago by anonymous

Attachment: audio_stream_problem.zip added

comment:1 Changed 12 years ago by danielk

Resolution: duplicate
Status: newclosed

Duplicate of #3153.

Note: See TracTickets for help on using tickets.