Opened 13 years ago

Closed 13 years ago

#3614 closed defect (fixed)

osx-packager runs out of space on its disk image when building MythTV (patch to increase default value)

Reported by: anonymous Owned by: Nigel
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: low Keywords: osx-packager osx
Cc: Ticket locked: no

Description

osx-packager.pl in the contrib directory will build a disk image, and then proceed to build all the files for Mythtv on that disk image. The default size for this disk image was previously specified at 1300m - but when I was attempting to build MythTV yesterday using this script, the image eventually filled up and the build failed.

I increased the value in the script to 3300m to fix this problem. A better long-term solution may be to have the size created depend upon the modules being built - (i.e. X megs for frontend, additional Y megs for plugins, and additional Z megs for backend) - but the amount of effort to do that simply isn't worth it IMHO since storage space is cheap and anyone who is running this build script probably knows how to edit the file.

Attachments (2)

osxpackager.diff (546 bytes) - added by ryebrye@… 13 years ago.
patch to increase the size of the disk image that the osx-packager.pl creates
osxpackager.2.diff (752 bytes) - added by ryebrye@… 13 years ago.
Increases size of disk image, and fixes download link for libmad

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by ryebrye@…

Attachment: osxpackager.diff added

patch to increase the size of the disk image that the osx-packager.pl creates

comment:1 Changed 13 years ago by ryebrye@…

I also noticed the download link for the libmad is broken. Sourceforge has libmad, so I have updated this patch to fix that link too... I've updated the patch that goes with this ticket to fix that too.

Changed 13 years ago by ryebrye@…

Attachment: osxpackager.2.diff added

Increases size of disk image, and fixes download link for libmad

comment:2 Changed 13 years ago by Nigel

Yes. Something changed in the last week that has blown this out. Still need to investigate what.
Disk space is cheap, but 3GB is a bit ridiculous. As someone who has about 5 build disk images on my MacBook?, you never have enough disk. I will test at around 2GB, and commit that if successful.

comment:3 Changed 13 years ago by ryebrye@…

Yeah, I put it up to 3.3 gigs just to avoid the hassle of guessing wrong before. I think the osx-packager.pl is building the backend by default now, but that may always be the intended behavior.

The link to the sourceforge for libmad I think is probably a better link to use.

I've got a few other snags I've been hitting and working through as I try to get my builds working - but I don't know if they are significant enough for their own tickets or if they are just unique to my setup. I've got notes on what they are and how I fixed them, if you email me sideband at my nick at gmail then I'll tell you what snags I've hit and where it's snagging at the moment.

comment:4 Changed 13 years ago by Nigel

Owner: changed from Isaac Richards to Nigel
Status: newassigned

OK. Cleaning before building shrinks the builds nearly to their previous sizes. A frontend-only build just fits in 1300MB, but a backend build now need about 1510MB. 2GB should be plenty of room to grow and cope with future bloated themes.

comment:5 Changed 13 years ago by Nigel

Resolution: fixed
Status: assignedclosed

(In [13706]) Larger build disk image, update a few URLs, add libogg for libvorbis. Closes #3614

Note: See TracTickets for help on using tickets.