Opened 13 years ago

Closed 13 years ago

#3615 closed defect (worksforme)

MythWeb Settings

Reported by: Andrew Allen <achew22@…> Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: mythweb Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When I attempt to change settings in MythWeb's channel settings tab (http://mythweb/settings/tv/channels) I change settings but they never take. This may be user error, but I've had a couple of people try it even on different computers, browsers, and operating systems.

Change History (15)

comment:1 Changed 13 years ago by stuartm

Component: mythtvmythweb
Owner: changed from Isaac Richards to xris

This has been fixed in SVN head ([13526]). You don't say which version you are using.

comment:2 Changed 13 years ago by Andrew Allen <achew22@…>

I did an update to 13713 and the problem remains. I tried to change "Use On Air Guide" to off.

comment:3 Changed 13 years ago by DannyCan@…

I am seeing this same problem when I try to turn off "Show pixmaps" and "Use myth:// URI for Windows" under "http://mythweb/settings/tv"
It will stay for the current session but when I go back it gets reset.

comment:4 Changed 13 years ago by Joe Ripley <vitaminjoe@…>

Works for me in [14537], even across multiple machines/browsers.

This might be a cookie issue. Check your browser settings. You could also try clearing out the mythweb_sessions table in the database. (i.e. DELETE FROM mythweb_sessions). This will clear your session profile from the database.

-- Joe Ripley vitaminjoe@…

comment:5 Changed 13 years ago by DannyCan@…

Joe, I don't really know the mysql commands.
Could you give me the exact commands that will clear the mythweb_sessions table?

Thanks[[BR]] DannyCan?

comment:6 Changed 13 years ago by Joe Ripley <vitaminjoe@…>

Sure, try this (assuming default username & password):

mysql -u mythtv -pmythtv mythconverg

mysql> DELETE FROM mythweb_sessions; mysql> exit

That should clear the table.

-- Joe Ripley vitaminjoe@…

comment:7 Changed 13 years ago by Rob Smith

Owner: changed from xris to Rob Smith
Status: newassigned

Is this still an issue? If I don't get a reply soon, I'll close the ticket.

comment:8 Changed 13 years ago by DannyCan@…

kormoc, Yes this is still an issue for me.
I tried vitaminjoe's commands and it had no effect.
I use Forefox in Ubuntu liunux and Windows XP and they both have this problem.
Today I tried switching recording groups and it reset without even leaving the recorded programs module.

comment:9 Changed 13 years ago by Rob Smith

Can you look up your AllowOverride? settings in your apache config files?

comment:10 Changed 13 years ago by DannyCan@…

kormoc, I'm not sure what setting I am looking for so I did this:

/etc# grep -R AllowOverride apache2/
apache2/sites-enabled/000-default:              AllowOverride All
apache2/sites-enabled/000-default:              AllowOverride None
apache2/sites-enabled/000-default:        AllowOverride None
apache2/sites-available/default:                AllowOverride All
apache2/sites-available/default:                AllowOverride None
apache2/sites-available/default:        AllowOverride None
apache2/mods-available/userdir.conf:                AllowOverride FileInfo AuthConfig Limit
apache2/conf.d/mythweb.conf:        AllowOverride   All
apache2/apache2.conf:# for additional configuration directives.  See also the AllowOverride
apache2/apache2.conf:        AllowOverride None
apache2/apache2.conf:#        AllowOverride None
/etc#

comment:11 Changed 13 years ago by Rob Smith

Can you guys try latest trunk and see if it's happy?

comment:12 Changed 13 years ago by DannyCan@…

kormoc, I updated to the latest trunk all across the board and now it's kind of different.
When I uncheck "Show pixmaps" it still shows the black pixmap box but with no picture in it.
I did however once take the pixmap black box away and loaded faster but now I can't get it to do it again.

comment:13 Changed 13 years ago by Rob Smith

DannyCan?,

That's not going to change, alas. With the icons for auto-expire and the streaming icons, it's using all that vertical space. It's not loading the pixmaps so it's gonna be faster, but it won't shrink anymore.

comment:14 Changed 13 years ago by DannyCan@…

Kormoc, I have seen it work in the past but if that's how it works now then that's the way it has to be I guess.

comment:15 Changed 13 years ago by Rob Smith

Resolution: worksforme
Status: acceptedclosed
Note: See TracTickets for help on using tickets.