Opened 12 years ago

Closed 12 years ago

#3620 closed defect (invalid)

Rev 13699 broken - missing symbol av_aes_size

Reported by: anonymous Owned by: Isaac Richards
Priority: blocker Milestone: unknown
Component: mythtv Version: head
Severity: high Keywords:
Cc: Ticket locked: no

Description

This just popped up this morning after compiling from SVN 13699 trunk:

root@mediaroom:/myth/svn/mythtv# ./configure --previous Options: --enable-dvb --enable-xvmc --enable-opengl-vsync --enable-proc-opt --prefix=/usr --arch=k8 --cpu=k8

[compile & install]

root@mediaroom:/myth/svn/mythtv# /etc/init.d/mythtv-backend restart Restarting MythTV server: mythbackendNo /usr/bin/mythbackend found running; none killed. . /usr/bin/mythbackend: symbol lookup error: /usr/lib/libmythavformat-0.20.so.0: undefined symbol: av_aes_size

root@mediaroom:/myth/svn/mythtv# svn update

At revision 13699.

Change History (6)

comment:1 Changed 12 years ago by scott.milliken@…

I forgot to mention, when reverting back to 13618 it works fine, using the same configuration options.

comment:2 Changed 12 years ago by paulh

Seems to be compiling/linking OK here. Did you try doing a make distclean to ensure everything is compiled afresh after the ffmpeg resync?

comment:3 Changed 12 years ago by scott.milliken@…

Yes, I've even deleted the source tree and resynched with svn since then and still get the same results. Apparently something I've done trying to get mythstream to work has borked a required library, but I can't figure out which one. Starting up with:

mythbackend -v all

Results in an immediate SegFault?, so I don't get any more information from trying to turn up logging.

comment:4 Changed 12 years ago by paulh

Could you have several versions of the libmyth* libraries installed in different locations and the run time linker is not using the versions you think it is?

comment:5 Changed 12 years ago by scott.milliken@…

Ok, that fixed it. To resolve, I did the following:

rm -f /lib/libmyth*

make distclean ./configure --previous make && make install /etc/init.d/mythtv-backend restart

It's now up and running fine. Thanks for the suggestion, Paul! Someone with the rights to close out this ticket is welcome to go right ahead.

comment:6 Changed 12 years ago by paulh

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.