Opened 14 years ago

Closed 14 years ago

#366 closed defect (duplicate)

Often DVB recordings miss subtitles

Reported by: riku.voipio@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

DVB subtitles seem to work well on livetv, but in many recordings are missing subtitles. Some closer research indicates, that that subtitles get recorded, if there was a subtitle stream at the start of recording.

However, if subtitle stream get added later, recording will not contain subtitles. This is often the case, if the previous program before the recorded program did not have DVB subtitles..

I think this may be a generic problem of not watching for changes in watched channels PIDs. As I understand, in a transport stream, PIDs can be changed/added/removed at anypoint. So recorded should not select streams to record in the beginning of recording, but keep track of them during the entire time of recording.

Change History (2)

comment:1 Changed 14 years ago by anonymous

I second this; they are called "dynamic subtitles" and have been used here in Finland for some time (actually from May onward).

comment:2 Changed 14 years ago by danielk

Resolution: duplicate
Status: newclosed

This appears to be a duplicate of #259.

Note: See TracTickets for help on using tickets.