Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#3687 closed patch (fixed)

Update to Channel sorting for QAM channels

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

My myth box consists of standard cable and QAM HD channels. I have labeled my QAM channels 4.1, 6.2, 6.3, 8.1, etc. When viewing the program guide the QAM channels weren't sorted in order with the cable channels. I've updated lt_smart so that it sorts as listed below. This will sort it the same for ., _, or - seperators (4.1, 4_1, 4-1)

2 4 4.1 6 6.2 6.3 6.4 8 8.1 9 9.1 11 11.1 13 13.1 16 17 18 etc..

The patch was created against SVN revision 13790. This is the first patch I've done in a long while so not sure if I did it quite right.

Attachments (1)

qam_lt_smart_sort.patch (2.6 KB) - added by billymacdonald@… 13 years ago.
Patch for QAM sort

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by billymacdonald@…

Attachment: qam_lt_smart_sort.patch added

Patch for QAM sort

comment:1 Changed 12 years ago by danielk

Owner: changed from Isaac Richards to danielk
Version: unknownhead

comment:2 Changed 12 years ago by danielk

Resolution: fixed
Status: newclosed

(In [14448]) Fixes #3687. Changes lt_smart sorting so that you can renumber channels with channel seperator.

This allows a little more flexibility in renumbering ATSC channels. I didn't use the patch by billymacdonald because it would sort 5_10 before 5_9 and the code was overly complex. This should address the same issues in a much simpler way.

comment:3 Changed 12 years ago by danielk

(In [14611]) Refs #3986. Refs #3687. This fixes a performance regression caused by [14448] which fixed the channel sorting problem reported in #3687. It does not fix the performance regression reported in #3986, but does lower the CPU usage slightly for me and significantly for Shane.

Note: See TracTickets for help on using tickets.