Opened 12 years ago

Closed 12 years ago

#3688 closed defect (duplicate)

MythDVD crashes on svn-versions >= 13775

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: 0.21
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Playing DVD'S ends in a segfault on playing DVD's with versions >= 13775, downgrading mythtv (not plugins) to 13572 solves the problem. The "crash-positions" are the same in a film but different with each film, so they are film-depend.

Attachments (1)

gdb.txt (31.3 KB) - added by treito@… 12 years ago.
gdb of mythfrontend

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by paulh

Resolution: invalid
Status: newclosed

Just saying it crashes is no use to us we need a backtrace.

http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

Also just to be sure are you using the internal player?

Re-open when a BT is available.

comment:2 Changed 12 years ago by stuartm

It might also help if you narrowed down which revision the bug was introduced. Two hundred revisions is a little too many.

comment:3 in reply to:  1 ; Changed 12 years ago by anonymous

Resolution: invalid
Status: closedreopened

@paulh Okay, see attached file.

@stuart I have no idea where to look, I couldn't compile 200 versions, it's only a Nehemia 1000MHz-CPU. perhaps you can give me a hint regarding gdb.txt and I could test some versions.

Changed 12 years ago by treito@…

Attachment: gdb.txt added

gdb of mythfrontend

comment:4 in reply to:  3 ; Changed 12 years ago by paulh

Replying to anonymous:

@stuart I have no idea where to look, I couldn't compile 200 versions, it's only a Nehemia 1000MHz-CPU. perhaps you can give me a hint regarding gdb.txt and I could test some versions.

I would suspect the ffmpeg resync in [13655] so try r13654 if that works OK then see if r13655 breaks things.

Does configure detect your processor properly? I would guess the Nehemia needs a specific set of compiler flags.

comment:5 in reply to:  4 Changed 12 years ago by Treito@…

Replying to paulh:

I would suspect the ffmpeg resync in [13655] so try r13654 if that works OK then see if r13655 breaks things.

Got this tip in #mythtv-de, too, will test it, but could take some time.

Does configure detect your processor properly? I would guess the Nehemia needs a specific set of compiler flags.

Yes, compiler-flag is C3-2, I'm not allowed to change anything or compilation fails.

comment:6 Changed 12 years ago by stuartm

You don't need to compile all 200. Install ccache if you haven't already, it will save you a lot of time. Then try a binary search, that means picking the version between the broken and working ones, repeating until you've narrowed it down to one. That way you only try maybe 5 revisions to find the culprit.

However as Paul suggests it's most likely the ffmpeg re-sync and something to do with the processor optimisations for your CPU. The segfault is occuring the in SSE fast fourier transform calculations.

Are you compiling with --enable-proc-opt?

comment:7 Changed 12 years ago by Janne Grunau

Resolution: duplicate
Status: reopenedclosed

duplicate of #3634

Note: See TracTickets for help on using tickets.