Opened 13 years ago

Closed 12 years ago

#3700 closed defect (wontfix)

mpegtables.h assertion fails when viewing recorded programs on mythweb

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I believe this has only happened when deleting a program which is the only one remaining from a particular show. As a result mythbackend crashes. After being restarted, it will work fully until I view recorded programs again from mythweb. This doesn't seem to be a problem with mythweb, since the code is unchanged in the current code of mpegtables.h, although it is now on line 528. Running the regular front-end doesn't appear to cause the same crash, but I have only used it this one time to test this bug.

Version: Library API version: 0.20.20060828-3

Here's the relevant portion of the log:

2007-07-06 15:33:58.555 adding: mythtv-backend as a client (events: 0)
2007-07-06 15:34:00.447 Preview Error: Previewer file '/var/lib/mythtv/1242_20070706062900.mpg' is not valid.
2007-07-06 15:34:00.454 MainServer: Failed to make preview image.
2007-07-06 15:34:00.458 MainServer::HandleAnnounce FileTransfer
2007-07-06 15:34:00.459 adding: mythtv-backend as a remote file transfer
2007-07-06 15:34:06.971 RingBuf(/var/lib/mythtv//1242_20070706062900.mpg.png): Could not open /var/lib/mythtv//1242_20070706062900.mpg.png.
2007-07-06 15:34:07.176 AFD: Opened codec 0x8288880, id(MPEG2VIDEO) type(Video)
2007-07-06 15:34:07.182 AFD: Opened codec 0x8288bc0, id(AC3) type(Audio)
0: start_time: -9223372036854.775 duration: 0.724
1: start_time: -9223372036854.775 duration: 0.674
stream: start_time: -9223372036854.775 duration: -9223372036854.775 bitrate=0 kb/s
2007-07-06 15:34:07.184 AFD: Warning, video codec 0x8288880 id(MPEG2VIDEO) type (Video) already open.
2007-07-06 15:34:07.186 AFD: Warning, audio codec 0x8288bc0 id(AC3) type (Audio) already open, leaving it alone.
2007-07-06 15:34:07.193 NVP: Disabling Audio, params(0,0,0)
mythbackend: mpeg/mpegtables.h:465: ProgramMapTable::ProgramMapTable(const PSIPTable&): Assertion `TableID::PMT == TableID()' failed.

Change History (1)

comment:1 Changed 12 years ago by danielk

Resolution: wontfix
Status: newclosed

Duplicate of #4561. svn head should not create broken recordings like this.

Note: See TracTickets for help on using tickets.