Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#371 closed defect (invalid)

Error with xmame 0.100

Reported by: anonymous Owned by: greg
Priority: critical Milestone: unknown
Component: mythgame Version: 0.18.1
Severity: high Keywords:
Cc: Ticket locked: no

Description

mythgame put "xmame version not supported" when try exec xmame -version. The problem is generated with the version of xmame is 0.100.

Change History (4)

comment:1 Changed 14 years ago by anonymous

xmame 0.100 don't accept '-history_file' param

comment:2 Changed 14 years ago by Isaac Richards

Resolution: invalid
Status: newclosed

Not a problem in svn.

comment:3 Changed 14 years ago by anonymous

Because the (old?) code said:

mamehandler.cpp:677: versionchk_string = (char*)malloc(3);

snprintf(versionchk_string, 3, "%s",

minor);

Which doesn't work for minor versions > 99.

Change 3s to 4s. (Or hack the binary and change the %s to 99...)

comment:4 Changed 14 years ago by anonymous

This is all gone in SVN so this patch isn't needed anymore.

Note: See TracTickets for help on using tickets.