Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#3720 closed patch (fixed)

Backend can recursively send messages to itself with a socket to connected to itself

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have been tracking down an issue that I have been seeing for a while now where my master backend will get into a nice loop where it will continually send BACKEND_MESSAGES to it's self, and in doing so process the message again, and repeat the process. This tends to make the backend not very responsive after that, and tho while it generally does not crash, it does not respond to things in a timely manner.

This is a snippet from a log showing the symptom: (pruned a bit w/ some of my debug)

2007-07-12 20:58:39.117 write -> 25 51      BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE[]:[]empty
2007-07-12 20:58:39.128 read  <- 22 51      BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE[]:[]empty
2007-07-12 20:58:39.178 MythEvent: RECORDING_LIST_CHANGE
2007-07-12 20:58:39.316 write -> 19 51      BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE[]:[]empty
2007-07-12 20:58:39.335 write -> 25 51      BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE[]:[]empty
2007-07-12 20:58:39.350 GAD: Got a event that we might want to redistribute RECORDING_LIST_CHANGE
2007-07-12 20:58:39.358 read  <- 22 51      BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE[]:[]empty
2007-07-12 20:58:39.374 MythEvent: RECORDING_LIST_CHANGE
2007-07-12 20:58:39.468 write -> 19 51      BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE[]:[]empty
2007-07-12 20:58:39.481 write -> 25 51      BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE[]:[]empty
2007-07-12 20:58:39.489 GAD: Got a event that we might want to redistribute RECORDING_LIST_CHANGE
2007-07-12 20:58:39.615 read  <- 22 51      BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE[]:[]empty
2007-07-12 20:58:39.646 MythEvent: RECORDING_LIST_CHANGE

I believe that the culprit to this problem is there are some cases where ConnectToMasterServer? can be called despite the fact that we *ARE* the master server. I see this in the log:

2007-07-12 22:31:27.930 read  <- 14 543     QUERY_GENPIXMAP[]:[]Modern Marvels[]:[]It Came From Outer Space[]...
2007-07-12 22:31:27.960 MythSocket(2aaaac1a1870:20): new socket
2007-07-12 22:31:27.973 Connecting to backend server: 192.168.1.10:6543 (try 1 of 5)
2007-07-12 22:31:27.982 MythSocket(2aaaac17bfe0:21): new socket
2007-07-12 22:31:27.990 MythSocket(2aaaac17bfe0:21): attempting connect() to (192.168.1.10:6543)
2007-07-12 22:31:27.998 MythSocket(2aaaac17bfe0:21): state change Idle -> Connected
2007-07-12 22:31:27.998 MythSocket(7183f0:23): new socket
2007-07-12 22:31:28.006 write -> 21 21      MYTH_PROTO_VERSION 34
2007-07-12 22:31:28.024 MythSocket(7183f0:23): setSocket: 22
2007-07-12 22:31:28.050 MythSocket(7183f0:22): state change Idle -> Connected
2007-07-12 22:31:28.058 MythSocket(7183f0:22): UpRef: 1
2007-07-12 22:31:28.066 MythSocket(7183f0:22): socket is readable
2007-07-12 22:31:28.081 MythSocket(7183f0:22): cb->readyRead()
2007-07-12 22:31:28.090 MythSocket(7183f0:22): UpRef: 2
2007-07-12 22:31:28.098 read  <- 22 21      MYTH_PROTO_VERSION 34
2007-07-12 22:31:28.102 write -> 22 13      ACCEPT[]:[]34
2007-07-12 22:31:28.103 read  <- 21 13      ACCEPT[]:[]34
2007-07-12 22:31:28.106 Using protocol version 34
2007-07-12 22:31:28.107 write -> 21 33      ANN Monitor palidor 0 pid8391
2007-07-12 22:31:28.103 MythSocket(7183f0:22): DownRef: 1
2007-07-12 22:31:28.108 MythSocket(7183f0:22): socket is readable
2007-07-12 22:31:28.118 MythSocket(7183f0:22): cb->readyRead()
2007-07-12 22:31:28.119 MythSocket(7183f0:22): UpRef: 2
2007-07-12 22:31:28.120 read  <- 22 33      ANN Monitor palidor 0 pid8391
2007-07-12 22:31:28.125 MainServer::HandleAnnounce Monitor
2007-07-12 22:31:28.126 adding: palidor as a client (events: 0)
2007-07-12 22:31:28.127 write -> 22 2       OK
2007-07-12 22:31:28.128 read  <- 21 2       OK
2007-07-12 22:31:28.134 MythSocket(2aaaac1a1870:20): attempting connect() to (192.168.1.10:6543)
2007-07-12 22:31:28.135 MythSocket(2aaaac1a1870:20): state change Idle -> Connected
2007-07-12 22:31:28.136 write -> 20 33      ANN Monitor palidor 1 pid8391
2007-07-12 22:31:28.135 MythSocket(87d140:24): new socket
2007-07-12 22:31:28.129 MythSocket(7183f0:22): DownRef: 1
2007-07-12 22:31:28.142 MythSocket(87d140:24): setSocket: 23
2007-07-12 22:31:28.154 MythSocket(87d140:23): state change Idle -> Connected
2007-07-12 22:31:28.156 MythSocket(87d140:23): UpRef: 1
2007-07-12 22:31:28.157 MythSocket(87d140:23): socket is readable
2007-07-12 22:31:28.164 MythSocket(87d140:23): cb->readyRead()
2007-07-12 22:31:28.166 MythSocket(87d140:23): UpRef: 2
2007-07-12 22:31:28.173 read  <- 23 33      ANN Monitor palidor 1 pid8391
2007-07-12 22:31:28.178 MainServer::HandleAnnounce Monitor
2007-07-12 22:31:28.182 adding: palidor as a client (events: 1)
2007-07-12 22:31:28.183 write -> 23 2       OK
2007-07-12 22:31:28.190 read  <- 20 2       OK

Once these extra sockets are created, it's only a matter of time before things going awry.

I think this can be re-created in several different ways, however I did find one sure fire one -- backtrace:

#0  MythContext::ConnectServer (this=0x6beab0, eventSock=0x2aaaac00e040, hostname=@0x4800fc60, port=6543, blockingClient=false)
    at mythcontext.cpp:880
#1  0x00002aaba6f1f97b in MythContext::ConnectToMasterServer (this=0x6beab0, blockingClient=false) at mythcontext.cpp:867
#2  0x00002aaba6f1fa88 in MythContext::SendReceiveStringList (this=0x6beab0, strlist=@0x4800fef0, quickTimeout=false, block=true)
    at mythcontext.cpp:2451
#3  0x00002aaba5a316bf in RemoteCheckFile (pginfo=0x2aaaac10ea00, checkSlaves=true) at remoteutil.cpp:117
#4  0x00002aaba599a18b in ProgramInfo::MarkAsInUse (this=0x2aaaac10ea00, inuse=true, usedFor=@0x48010370) at programinfo.cpp:4019
#5  0x00002aaba5c65886 in NuppelVideoPlayer (this=0x2aaaac183720, inUseID=@0x480106d0, info=0x2aaaac116640)
    at NuppelVideoPlayer.cpp:269
#6  0x00002aaba5af8018 in PreviewGenerator::GetScreenGrab (pginfo=0x2aaaac116640, filename=@0x2aaaac1166a0, secondsin=64,
    bufferlen=@0x4801087c, video_width=@0x48010878, video_height=@0x48010874, video_aspect=@0x48010870) at previewgenerator.cpp:481
#7  0x000000000044b8e4 in MainServer::HandleGenPreviewPixmap (this=0x2aaaac00af50, slist=@0x48010dd0, pbs=0x2aaaac0354d0)
    at mainserver.cpp:3580

What I do here is using mythweb to retrieve the recording list, it needs to generate a pixmap for a recording that was recorded on a slave backend.

I'd make a patch to fix something here, but I'm not sure appropriate fix, and/or which aspect of this is a bug vs a feature.

Some Questions: Is it ok for the MBE to open a socket to himself to receive events on? Is it ok for the MBE to redistribute BACKEND_MESSAGES to all of the sockets connected? or should there be a recursion check in there?

I've found this one case that will reproduce it, but I have a hunch there there are more. (like the clearsettingscache on backend/main.cpp:487 seems like it would also trigger it.) Obviously it might be better to prevent the "bad stuff" from occuring, rather than trying to track down all of the places that open sockets to the MBE.

If a dev wants to make a suggestion of how to proceed, then I'll gladly patch/test this case. I finally took the time to track it down, but this has been plaguing me for months. I have also noticed another with this problem: http://www.gossamer-threads.com/lists/mythtv/users/270452

My myth config if it matters: Master BE/FE with 2 HD tuners and *all* the storage. [diskless] slave BE/FE with pvr-150 recording to nfs storage on master. MBO is on. Addtional frontends.

Any questions, feel free.

Attachments (5)

no-master-connect2.patch (1.1 KB) - added by anonymous 12 years ago.
preview_doesnt_do_remotecheckfile.patch (825 bytes) - added by anonymous 12 years ago.
ismasterbackend_checkbackend.patch (416 bytes) - added by Rob Smith 12 years ago.
Update for [14462]
3720-preview-problem-v1.patch (2.4 KB) - added by danielk 12 years ago.
preview_doesnt_do_remotecheckfile.patch fixed in a more foolproof way (But I still haven't verified this fix).
3720-event-socket-v1.patch (989 bytes) - added by danielk 12 years ago.
Event socket issue fixed with a warning when possibly used incorrectly.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 12 years ago by gdragon at jetcom dt org

my email

comment:2 Changed 12 years ago by michael bishop <clever@…>

http://pastebin.ca/650303 backtrace of the master backend the instant it connected to itself all i did was set a breakpoint on the function that connects and bt when it stoped

comment:3 Changed 12 years ago by michael bishop <clever@…>

ive tracked the problem down some

when the mbe trys to generate a preview for an image on a slave backend it calls PreviewGenerator::GetScreenGrab?

which then calls NuppelVideoPlayer?

which marks the file as inuse using ProgramInfo::MarkAsInUse?

which uses RemoteCheckFile? to check on the file status

which uses MythContext::SendReceiveStringList? to query the mbe for some info

MythContext::SendReceiveStringList? seems to allways open a socket to the master backend, even if this is the master backend

not shure how to fix it but i think RemoteCheckFile? needs to be modified so if its on the mbe it will just check the local data instead of connecting to itself and causing the feedback

comment:4 Changed 12 years ago by gdragon at jetcom.org

I have developed 2 patches that seem to solve this problem. At least in my testing they cover the aforementioned reproducible scenario.

One is in the camp of "don't do that it hurts" and the other is a "good" fix imho.

The "good" fix prevents the MBE from opening an event socket to receive "Events" on. If a socket is opened to get these events, the MBE will try to send an event to himself, and it will go into an infinite recursion loop. This is bad. The fix entails adding a check to ConnectMasterServer? and checking IsMasterBackend? before blindly opening this socket. We still will create the serverSock that is used to query the MBE, this socket is not strictly required, since we are the MBE, but it allows for all the socket calls on there to just work.
This patch is good since it protects against this problem occurring in the future (or already lurking) calls to ConnectMasterServer? or any number of functions that call it are called from the MBE, such as SendReceiveStringList?.
This patch is attached as no-master-connect2.patch

The "don't do that it hurts" patch prevents the one case noted above from calling RemoteCheckFile?. RemoteCheckFile? is only used to obtain the recording directory of a potentially currently recording file. The preview generator does not require this info, and shouldn't affect the use of recDir which is apparently StorageGroups?. Michael Bishop pointed out to me that the NVP is invoked with a user of "Preview" rather than "preview_generator". The attached patch simply renames the user and does not trigger the check of recdir.
It is attached as preview_doesnt_do_remotecheckfile.patch

Personally I think that both of these patches should be incorporated into the tree. The second solves the one case that I found to recreate this problem, but I have a feeling that there are/will be more. The 1st patch should prevent any further problems like these from creeping in.

Any questions/comments feel free.

Changed 12 years ago by anonymous

Attachment: no-master-connect2.patch added

Changed 12 years ago by anonymous

Changed 12 years ago by Rob Smith

Update for [14462]

comment:5 Changed 12 years ago by Rob Smith

Updated the ismasterbackend patch so it works with current trunk

comment:6 Changed 12 years ago by danielk

Milestone: unknown0.21
Owner: changed from Isaac Richards to danielk
Type: defectpatch

comment:7 Changed 12 years ago by devel@…

Your latest patch (ismasterbackend_checkbackend) changes the behaviour of ismasterbackend to return true only if the backend is running. This is not acceptable.
See http://svn.mythtv.org/trac/ticket/3280 for more details.

comment:8 in reply to:  7 Changed 12 years ago by anonymous

Replying to devel@mrwire.co.uk:

Your latest patch (ismasterbackend_checkbackend) changes the behaviour of ismasterbackend to return true only if the backend is running. This is not acceptable.
See http://svn.mythtv.org/trac/ticket/3280 for more details.

Agreed. The patch attached to 3280 is better, and is now applied to trunk. Ignore the latest patch (ismasterbackend_checkbackend)

comment:9 Changed 12 years ago by danielk

Resolution: fixed
Status: newclosed

Fixed by [14473], [14475]. Refs #3280.

comment:10 Changed 12 years ago by gdragon

Resolution: fixed
Status: closedreopened

Sorry, I guess the previous message was unclear.

The fixes applied in #3280 do not fix this issue. They are only support functions that are used by it.

The two patches (no-master-connect2.patch) and (preview_doesnt_do_remotecheckfile.patch ) are still applicable, and at least one is need to fix this problem.

I did an update and verified that they still applied with the latest changes at trunk such as #3280, etc.

Changed 12 years ago by danielk

preview_doesnt_do_remotecheckfile.patch fixed in a more foolproof way (But I still haven't verified this fix).

Changed 12 years ago by danielk

Attachment: 3720-event-socket-v1.patch added

Event socket issue fixed with a warning when possibly used incorrectly.

comment:11 Changed 12 years ago by danielk

I've looked at the code for these patches, it looks like it may be ok. But I need to reproduce the actual problem, which means adding a slave to my dev machine setup again, and then I'll let it sit around a while in my tree to make sure it doesn't cause any new problems here before committing anything.

comment:12 Changed 12 years ago by Rob Smith

Daniel,

I have this issue with only a single box. I have a shared backend/frontend on the same machine and without this patch, it messages itself into crashing.

I'm really not sure what triggered it, but I did restore a db from a different machine (different hostname). Previous to this restore, it worked fine.

comment:13 Changed 12 years ago by danielk

(In [14691]) Refs #3720. Make preview generator play nice with storage groups.

We were using two different in use tags, but only checking for one of them in ProgramInfo::MarkAsInUse?(). This just uses one of them in MarkAsInUse? and uses a constant variable for the string so that this isn't changed accidentally in the future.

comment:14 Changed 12 years ago by danielk

Resolution: fixed
Status: reopenedclosed

After talking to Isaac I'm not going to commit the event socket portion of this. It looks like the event socket might be used on the master backend when communicating with slave backends. We simply have to try to avoid event loops in the code, as the already applied changeset for the preview generator does.

comment:15 Changed 9 years ago by jari.forsman@…

Running 0.23-fixes on ubuntu 10.04 LTS mythtv-backends go nuts.. Master sends events to slave that go loop..

2010-06-05 21:06:36.949 MythSocket?(180ce50:35): write -> 35 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:36.993 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 72576836 2010-06-05 21:06:37.007 MythSocket?(180ce50:35): write -> 35 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:37.016 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 770... 2010-06-05 21:06:37.024 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 725... 2010-06-05 21:06:37.032 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 77091092 2010-06-05 21:06:37.049 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 678... 2010-06-05 21:06:37.049 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 770... 2010-06-05 21:06:37.057 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 67808592 2010-06-05 21:06:37.074 MythSocket?(17a6f30:11): read <- 11 78 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 201... 2010-06-05 21:06:37.074 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 678... 2010-06-05 21:06:37.082 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 201912 2010-06-05 21:06:37.099 MythSocket?(17a6f30:11): read <- 11 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:37.099 MythSocket?(180ce50:35): write -> 35 78 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 201... 2010-06-05 21:06:37.107 MythEvent?: SYSTEM_EVENT SCHEDULER_RAN SENDER daphne 2010-06-05 21:06:37.124 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 531... 2010-06-05 21:06:37.124 MythSocket?(180ce50:35): write -> 35 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:37.132 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 53130116 2010-06-05 21:06:37.149 MythSocket?(17a6f30:11): read <- 11 130 BACKEND_MESSAGE[]:[]SYSTEM_EVENT REC_STARTED CARDID 8 CHANID 1118... 2010-06-05 21:06:37.149 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 531... 2010-06-05 21:06:37.157 MythEvent?: SYSTEM_EVENT REC_STARTED CARDID 8 CHANID 1118 STARTTIME 2010-06-05T21:04:00 SENDER mythbuntu-olkkari 2010-06-05 21:06:37.174 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 426... 2010-06-05 21:06:37.174 MythSocket?(180ce50:35): write -> 35 130 BACKEND_MESSAGE[]:[]SYSTEM_EVENT REC_STARTED CARDID 8 CHANID 1118... 2010-06-05 21:06:37.182 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 42648176 2010-06-05 21:06:37.199 MythSocket?(17a6f30:11): read <- 11 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 616... 2010-06-05 21:06:37.199 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 426... 2010-06-05 21:06:37.207 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 6161700 2010-06-05 21:06:37.224 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 217... 2010-06-05 21:06:37.224 MythSocket?(180ce50:35): write -> 35 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 616... 2010-06-05 21:06:37.232 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 21768332 2010-06-05 21:06:37.249 MythSocket?(17a6f30:11): read <- 11 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 431... 2010-06-05 21:06:37.249 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 217... 2010-06-05 21:06:37.257 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 4314976 2010-06-05 21:06:37.274 MythSocket?(17a6f30:11): read <- 11 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 127... 2010-06-05 21:06:37.274 MythSocket?(180ce50:35): write -> 35 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 431... 2010-06-05 21:06:37.309 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 1271820 2010-06-05 21:06:37.332 MythSocket?(17a6f30:11): read <- 11 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 232... 2010-06-05 21:06:37.332 MythSocket?(180ce50:35): write -> 35 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 127... 2010-06-05 21:06:37.340 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 2325936 2010-06-05 21:06:37.357 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 113... 2010-06-05 21:06:37.357 MythSocket?(180ce50:35): write -> 35 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 232... 2010-06-05 21:06:37.365 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 11346176 2010-06-05 21:06:37.382 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 270... 2010-06-05 21:06:37.390 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 27025188 2010-06-05 21:06:37.382 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 113... 2010-06-05 21:06:37.399 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE ADD 1118 2010-06-05T21:... 2010-06-05 21:06:37.407 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 270... 2010-06-05 21:06:37.415 MythEvent?: RECORDING_LIST_CHANGE ADD 1118 2010-06-05T21:04:00 2010-06-05 21:06:37.432 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 322... 2010-06-05 21:06:37.432 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE ADD 1118 2010-06-05T21:... 2010-06-05 21:06:37.440 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 81812148 2010-06-05 21:06:37.440 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 32238616 2010-06-05 21:06:37.457 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 818... 2010-06-05 21:06:37.465 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 478... 2010-06-05 21:06:37.474 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 322... 2010-06-05 21:06:37.482 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 47866116 2010-06-05 21:06:37.499 MythSocket?(17a6f30:11): read <- 11 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:37.499 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 478... 2010-06-05 21:06:37.507 MythEvent?: SCHEDULE_CHANGE 2010-06-05 21:06:37.524 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 582... 2010-06-05 21:06:37.524 MythSocket?(180ce50:35): write -> 35 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:37.532 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 58298048 2010-06-05 21:06:37.549 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 165... 2010-06-05 21:06:37.549 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 582... 2010-06-05 21:06:37.557 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 16552460 2010-06-05 21:06:37.574 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 165... 2010-06-05 21:06:37.574 MythSocket?(17a6f30:11): read <- 11 653 BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE UPDATE[]:[]Top Gear[]:[... 2010-06-05 21:06:37.590 MythEvent?: RECORDING_LIST_CHANGE UPDATE 2010-06-05 21:06:37.676 MythSocket?(17a6f30:11): read <- 11 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 529... 2010-06-05 21:06:37.676 MythSocket?(180ce50:35): write -> 35 653 BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE UPDATE[]:[]Top Gear[]:[... 2010-06-05 21:06:37.734 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 5295396 2010-06-05 21:06:37.757 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 634... 2010-06-05 21:06:37.757 MythSocket?(180ce50:35): write -> 35 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 529... 2010-06-05 21:06:37.765 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 63428192 2010-06-05 21:06:37.782 MythSocket?(17a6f30:11): read <- 11 99 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SLAVE_CONNECTED HOSTNAME mythbun... 2010-06-05 21:06:37.782 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 634... 2010-06-05 21:06:37.790 MythEvent?: SYSTEM_EVENT SLAVE_CONNECTED HOSTNAME mythbuntu-olkkari SENDER daphne 2010-06-05 21:06:37.807 MythSocket?(180ce50:35): write -> 35 99 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SLAVE_CONNECTED HOSTNAME mythbun... 2010-06-05 21:06:37.807 MythSocket?(17a6f30:11): read <- 11 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 333... 2010-06-05 21:06:37.823 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 3330608 2010-06-05 21:06:37.832 MythSocket?(17a6f30:11): read <- 11 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:37.832 MythSocket?(180ce50:35): write -> 35 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 333... 2010-06-05 21:06:37.840 MythEvent?: SYSTEM_EVENT SCHEDULER_RAN SENDER daphne 2010-06-05 21:06:37.857 MythSocket?(180ce50:35): write -> 35 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:37.857 MythSocket?(17a6f30:11): read <- 11 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:37.873 MythEvent?: SCHEDULE_CHANGE 2010-06-05 21:06:37.882 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 374... 2010-06-05 21:06:37.882 MythSocket?(180ce50:35): write -> 35 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:37.890 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 37408240 2010-06-05 21:06:37.907 MythSocket?(17a6f30:11): read <- 11 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:37.907 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 374... 2010-06-05 21:06:37.915 MythEvent?: SYSTEM_EVENT SCHEDULER_RAN SENDER daphne 2010-06-05 21:06:37.932 MythSocket?(17a6f30:11): read <- 11 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:37.932 MythSocket?(180ce50:35): write -> 35 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:37.940 MythEvent?: SCHEDULE_CHANGE 2010-06-05 21:06:37.957 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 725... 2010-06-05 21:06:37.957 MythSocket?(180ce50:35): write -> 35 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:37.965 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 72576836 2010-06-05 21:06:37.982 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 770... 2010-06-05 21:06:37.982 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 725... 2010-06-05 21:06:37.990 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 77091092 2010-06-05 21:06:38.007 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 678... 2010-06-05 21:06:38.007 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 770... 2010-06-05 21:06:38.015 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 67808592 2010-06-05 21:06:38.067 MythSocket?(17a6f30:11): read <- 11 78 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 201... 2010-06-05 21:06:38.067 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 678... 2010-06-05 21:06:38.082 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 201912 2010-06-05 21:06:38.098 MythSocket?(17a6f30:11): read <- 11 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:38.098 MythSocket?(180ce50:35): write -> 35 78 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 201... 2010-06-05 21:06:38.107 MythEvent?: SYSTEM_EVENT SCHEDULER_RAN SENDER daphne 2010-06-05 21:06:38.123 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 531... 2010-06-05 21:06:38.123 MythSocket?(180ce50:35): write -> 35 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:38.132 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 53130116 2010-06-05 21:06:38.148 MythSocket?(17a6f30:11): read <- 11 130 BACKEND_MESSAGE[]:[]SYSTEM_EVENT REC_STARTED CARDID 8 CHANID 1118... 2010-06-05 21:06:38.148 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 531... 2010-06-05 21:06:38.157 MythEvent?: SYSTEM_EVENT REC_STARTED CARDID 8 CHANID 1118 STARTTIME 2010-06-05T21:04:00 SENDER mythbuntu-olkkari 2010-06-05 21:06:38.173 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 426... 2010-06-05 21:06:38.173 MythSocket?(180ce50:35): write -> 35 130 BACKEND_MESSAGE[]:[]SYSTEM_EVENT REC_STARTED CARDID 8 CHANID 1118... 2010-06-05 21:06:38.182 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 42648176 2010-06-05 21:06:38.198 MythSocket?(17a6f30:11): read <- 11 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 616... 2010-06-05 21:06:38.198 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 426... 2010-06-05 21:06:38.206 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 6161700 2010-06-05 21:06:38.223 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 217... 2010-06-05 21:06:38.223 MythSocket?(180ce50:35): write -> 35 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 616... 2010-06-05 21:06:38.231 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 21768332 2010-06-05 21:06:38.248 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 217... 2010-06-05 21:06:38.248 MythSocket?(17a6f30:11): read <- 11 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 431... 2010-06-05 21:06:38.265 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 4314976 2010-06-05 21:06:38.273 MythSocket?(17a6f30:11): read <- 11 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 127... 2010-06-05 21:06:38.282 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 1271820 2010-06-05 21:06:38.290 MythSocket?(17a6f30:11): read <- 11 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 232... 2010-06-05 21:06:38.323 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 2325936 2010-06-05 21:06:38.331 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 113... 2010-06-05 21:06:38.340 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 11346176 2010-06-05 21:06:38.348 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 270... 2010-06-05 21:06:38.356 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 27025188 2010-06-05 21:06:38.365 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE ADD 1118 2010-06-05T21:... 2010-06-05 21:06:38.373 MythEvent?: RECORDING_LIST_CHANGE ADD 1118 2010-06-05T21:04:00 2010-06-05 21:06:38.273 MythSocket?(180ce50:35): write -> 35 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 431... 2010-06-05 21:06:38.382 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 818... 2010-06-05 21:06:38.425 MythSocket?(180ce50:35): write -> 35 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 127... 2010-06-05 21:06:38.440 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 81812148 2010-06-05 21:06:38.448 MythSocket?(180ce50:35): write -> 35 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 232... 2010-06-05 21:06:38.456 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 322... 2010-06-05 21:06:38.465 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 113... 2010-06-05 21:06:38.473 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 32238616 2010-06-05 21:06:38.481 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 270... 2010-06-05 21:06:38.490 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 478... 2010-06-05 21:06:38.498 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE ADD 1118 2010-06-05T21:... 2010-06-05 21:06:38.506 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 47866116 2010-06-05 21:06:38.515 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 818... 2010-06-05 21:06:38.523 MythSocket?(17a6f30:11): read <- 11 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:38.531 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 322... 2010-06-05 21:06:38.540 MythEvent?: SCHEDULE_CHANGE 2010-06-05 21:06:38.548 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 478... 2010-06-05 21:06:38.556 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 582... 2010-06-05 21:06:38.565 MythSocket?(180ce50:35): write -> 35 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:38.573 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 58298048 2010-06-05 21:06:38.590 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 165... 2010-06-05 21:06:38.590 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 582... 2010-06-05 21:06:38.598 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 16552460 2010-06-05 21:06:38.615 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 165... 2010-06-05 21:06:38.615 MythSocket?(17a6f30:11): read <- 11 653 BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE UPDATE[]:[]Top Gear[]:[... 2010-06-05 21:06:38.631 MythEvent?: RECORDING_LIST_CHANGE UPDATE 2010-06-05 21:06:38.640 MythSocket?(17a6f30:11): read <- 11 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 529... 2010-06-05 21:06:38.640 MythSocket?(180ce50:35): write -> 35 653 BACKEND_MESSAGE[]:[]RECORDING_LIST_CHANGE UPDATE[]:[]Top Gear[]:[... 2010-06-05 21:06:38.648 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 5295396 2010-06-05 21:06:38.665 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 634... 2010-06-05 21:06:38.665 MythSocket?(180ce50:35): write -> 35 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 529... 2010-06-05 21:06:38.673 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 63428192 2010-06-05 21:06:38.690 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 634... 2010-06-05 21:06:38.690 MythSocket?(17a6f30:11): read <- 11 99 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SLAVE_CONNECTED HOSTNAME mythbun... 2010-06-05 21:06:38.706 MythEvent?: SYSTEM_EVENT SLAVE_CONNECTED HOSTNAME mythbuntu-olkkari SENDER daphne 2010-06-05 21:06:38.742 MythSocket?(17a6f30:11): read <- 11 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 333... 2010-06-05 21:06:38.742 MythSocket?(180ce50:35): write -> 35 99 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SLAVE_CONNECTED HOSTNAME mythbun... 2010-06-05 21:06:38.756 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 3330608 2010-06-05 21:06:38.773 MythSocket?(17a6f30:11): read <- 11 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:38.773 MythSocket?(180ce50:35): write -> 35 79 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 333... 2010-06-05 21:06:38.781 MythEvent?: SYSTEM_EVENT SCHEDULER_RAN SENDER daphne 2010-06-05 21:06:38.798 MythSocket?(180ce50:35): write -> 35 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:38.798 MythSocket?(17a6f30:11): read <- 11 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:38.815 MythEvent?: SCHEDULE_CHANGE 2010-06-05 21:06:38.823 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 374... 2010-06-05 21:06:38.823 MythSocket?(180ce50:35): write -> 35 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:38.831 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 37408240 2010-06-05 21:06:38.848 MythSocket?(17a6f30:11): read <- 11 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:38.848 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 374... 2010-06-05 21:06:38.856 MythEvent?: SYSTEM_EVENT SCHEDULER_RAN SENDER daphne 2010-06-05 21:06:38.873 MythSocket?(17a6f30:11): read <- 11 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:38.873 MythSocket?(180ce50:35): write -> 35 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:38.881 MythEvent?: SCHEDULE_CHANGE 2010-06-05 21:06:38.898 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 725... 2010-06-05 21:06:38.906 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 72576836 2010-06-05 21:06:38.898 MythSocket?(180ce50:35): write -> 35 45 BACKEND_MESSAGE[]:[]SCHEDULE_CHANGE[]:[]empty 2010-06-05 21:06:38.915 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 770... 2010-06-05 21:06:38.923 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 725... 2010-06-05 21:06:38.931 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 77091092 2010-06-05 21:06:38.948 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 678... 2010-06-05 21:06:38.948 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 770... 2010-06-05 21:06:38.956 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 67808592 2010-06-05 21:06:38.973 MythSocket?(17a6f30:11): read <- 11 78 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 201... 2010-06-05 21:06:38.973 MythSocket?(180ce50:35): write -> 35 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 678... 2010-06-05 21:06:38.981 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 201912 2010-06-05 21:06:38.998 MythSocket?(17a6f30:11): read <- 11 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:38.998 MythSocket?(180ce50:35): write -> 35 78 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 201... 2010-06-05 21:06:39.006 MythEvent?: SYSTEM_EVENT SCHEDULER_RAN SENDER daphne 2010-06-05 21:06:39.023 MythSocket?(17a6f30:11): read <- 11 80 BACKEND_MESSAGE[]:[]UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 531... 2010-06-05 21:06:39.031 MythEvent?: UPDATE_FILE_SIZE 1118 2010-06-05T21:04:00 53130116 2010-06-05 21:06:39.040 MythSocket?(17a6f30:11): read <- 11 130 BACKEND_MESSAGE[]:[]SYSTEM_EVENT REC_STARTED CARDID 8 CHANID 1118... 2010-06-05 21:06:39.023 MythSocket?(180ce50:35): write -> 35 70 BACKEND_MESSAGE[]:[]SYSTEM_EVENT SCHEDULER_RAN SENDER daphne[]:[]... 2010-06-05 21:06:39.083 MythEvent?: SYSTEM_EVENT REC_STARTED CARDID 8 CHANID 1118 STARTTIME 2010-06-05T21:04:00 SENDER mythbuntu-olkkari

Note: See TracTickets for help on using tickets.