Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#3749 closed defect (fixed)

mytharchive main, chapter menus missing titles

Reported by: anonymous Owned by: paulh
Priority: minor Milestone: 0.21
Component: mytharchive Version: head
Severity: low Keywords: mytharchive missing title
Cc: Ticket locked: no

Description

After running mytharchive on a recording, the resulting main and chapter menus are lacking the titles of the program(s). The description text DOES appear (see attached screenshot). This happens regardless of which theme is selected (I tried MythCenter?, G.A.N.T. and Compact).

This is with mytharchive svn 13814 (x86_64 version)

Attachments (1)

background-1.jpg (25.3 KB) - added by anonymous 12 years ago.
Screenshot showing titles missing from main menu

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by anonymous

Attachment: background-1.jpg added

Screenshot showing titles missing from main menu

comment:1 Changed 12 years ago by sphery <mtdean@…>

comment:2 Changed 12 years ago by anonymous

(original poster) Confirmed that this is the problem. Reverted to prior fonts and titles are fine again. Case can be closed. Thanks!

comment:3 Changed 12 years ago by paulh

Component: mythtvmytharchive
Milestone: unknown0.21
Owner: changed from Isaac Richards to paulh

comment:4 Changed 12 years ago by paulh

Resolution: fixed
Status: newclosed

(In [14025]) Work around a problem introduced with the new FreeSans?.ttf added to svn recently that was causing the DVD menus created in MythArchive? to have missing text elements.

  • Changes the way the script calculates the width and height of text so that it will work consistently with all fonts regardless of how a font reports its metrics.
  • Change the way fonts are defined in theme files.
    • Font definitions now have a name and can be referred to by name in text elements.
    • The color can be defined in the font definition.
    • Add new 'shadow' and 'outline' font drawing effects.
    • Add new 'shadowsize' and 'shadowcolor' font attributes.

See the changes in themes/MythCenter/theme.xml for an example of how the new font definitions should be used.

The font definition changes are backwards compatible so old themes should still work OK.

  • There's a number of changes that improve the image quality of the jpegs that that are used to create the final DVD menus.

TODO: - Convert all the existing themes to use the new font definitions.

  • Check the positioning of all text elements is still OK since these changes alter the positioning slightly.
  • Change some of the themes to use the new text styles where appropriate.

Fixes #3749.

comment:5 Changed 9 years ago by sphery

(In [25382]) Update the FreeFont? fonts distributed with MythTV to the current 20090104 version.

The 20060126 version we were previously distributing had some kerning issues that are now apparent since the OSD is rendered using MythUI (which uses Qt library code) rather than our own custom freetype code. Note, also, that MythArchive? was modified to work with the old FreeFont? fonts in [14025], but the description makes it sound like the new fonts will work, too.

Refs #3749. Fixes #8674. Thanks to Jim Stichnoth for testing and identifying the issue.

Note: See TracTickets for help on using tickets.