Opened 12 years ago

Closed 12 years ago

#3755 closed patch (fixed)

The wrong buttom is selected after playing a title

Reported by: Steve VanDeBogart <vandebo-mythtvtrac@…> Owned by: paulh
Priority: minor Milestone: 0.21
Component: mytharchive Version: 0.20
Severity: medium Keywords: button selected
Cc: Ticket locked: no

Description

After playing the 2nd or 3rd title on not the first page of titles, the button selected after playing the title is not the same as the button selected before playing the title (as it is on the first page, or for the first title on each page).

The problem is caused by the order that the buttons are written to the dvdauthor.xml file.

The attached patch corrects the error by delaying the write-out of the xml for next/previous buttons until the end of the page.

Attachments (1)

button-order.patch (1.6 KB) - added by Steve VanDeBogart <vandebo-mythtvtrac@…> 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by Steve VanDeBogart <vandebo-mythtvtrac@…>

Attachment: button-order.patch added

comment:1 Changed 12 years ago by stuartm

Component: mythtvmytharchive
Owner: changed from Isaac Richards to paulh

Please make sure you select the correct 'component' in future.

comment:2 Changed 12 years ago by paulh

Milestone: unknown0.21

comment:3 Changed 12 years ago by paulh

Resolution: fixed
Status: newclosed

(In [14028]) Fix a problem with the DVDs created by MythArchive? with more than one page of titles where the wrong button sometimes gets the focus after playing a title.

Closes #3755. Patch by Steve VanDeBogart?.

Note: See TracTickets for help on using tickets.