Opened 12 years ago

Closed 12 years ago

#3756 closed defect (fixed)

Ejecting DVD interrupts Internal Viewer

Reported by: g8ecj@… Owned by: Nigel
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

If during LiveTV, WatchTV or Video when the Internal Viewer is running a DVD or CD is ejected by pressing the button on the drive, the viewer exits back to the main (top level) menu. Its not the same as 'escape', more like a JumpMainMenu? event.

Occuring in r13951 HEAD, other versions not tried.

Change History (5)

comment:1 Changed 12 years ago by g8ecj@…

Doesn't trac *ever* get the email address right? (yes it was me reported it!)

comment:2 in reply to:  1 Changed 12 years ago by Nick Morrott <<knowledgejunkie [at] gmail [dot] com>>

Replying to g8ecj@gilks.org:

Doesn't trac *ever* get the email address right? (yes it was me reported it!)

If you haven't saved your name/email on trac's Preferences page, it seems the field is always set to anonymous.

comment:3 Changed 12 years ago by Nigel

Owner: changed from Isaac Richards to Nigel
Status: newassigned

Robin Gilks kindly mailed some "-v media" log:

2007-08-14 17:25:20.929 TV: Changing from None to WatchingLiveTV
...
2007-08-14 17:25:31.064 NVP: prebuffering pause
2007-08-14 17:25:31.094 /dev/cdrom Disk OK...
...
2007-08-14 17:25:34.358 /dev/cdrom Tray open
2007-08-14 17:25:34.359 Posting MediaEvent (MEDIATYPE_DVD, MEDIASTAT_USEABLE -> MEDIASTAT_OPEN)
2007-08-14 17:25:34.360 Found a handler
2007-08-14 17:25:34.397 TV: Attempting to change from WatchingLiveTV to None
2007-08-14 17:25:34.656 TV: Changing from WatchingLiveTV to None

That is from a r14158 frontend. As soon as the media event is posted, TV exits.

That looks like something to do with my change [13877], but I don't know why I am not seeing it. Am guessing that TV::customEvent() is not detecting Media events?

comment:4 Changed 12 years ago by Nigel

Reporter: changed from anonymous to g8ecj@…

OK. On a different test machine, can now reproduce. Changeset 13877 created the new behaviour - it sends a media eject (UNUSABLE) event, which at the moment can only be received by the plugin if its window is active, so mythmainwindow jumps to it.

Now, my quandary is - what should it do? If Monitor CD/DVD is on, but the user is watching TV or a recording, do we ignore all media change events? Or do we only want to ignore eject events?

The former can be achieved by turning the media monitoring off while watching TV, or Video. The latter might require changing the whole media notification system. Or maybe something quick and dirty like moving gCDdevice and gDVDdevice into MythMediaMonitor's namespace.

comment:5 Changed 12 years ago by Nigel

Resolution: fixed
Status: assignedclosed

(In [14502]) Don't jump to the main menu for "eject" media events. Closes #3756 (I hope :-)

Note: See TracTickets for help on using tickets.