Opened 14 years ago

Closed 14 years ago

#377 closed defect (fixed)

Pausing/hiccups while watching recordings

Reported by: tom@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I'm sure this was mentioned already, but using relatively current SVN (7308), I am seeing strangeness when watching recordings. The log is from a recording that I was watching as it was recording, with no comm-flagging occurring at the time, standard TV from a PVR-250. The problem mostly appeared when I was catching up to 'real time', but it was anywhere from 3-10 minutes from that point, so I'm not sure if that is relevant. Most of the log looks similar to this:

2005-09-25 17:35:46.072 prebuffering pause 2005-09-25 17:35:46.088 prebuffering pause 2005-09-25 17:35:46.684 playing at normal speed from falling behind... 2005-09-25 17:35:46.690 Changing time stretch to 1.2 2005-09-25 17:35:47.185 prebuffering pause 2005-09-25 17:35:47.186 playing slower due to falling behind... 2005-09-25 17:35:47.349 Changing time stretch to 0.96 2005-09-25 17:35:47.356 prebuffering pause 2005-09-25 17:35:47.364 prebuffering pause 2005-09-25 17:35:47.383 prebuffering pause 2005-09-25 17:35:47.397 prebuffering pause 2005-09-25 17:35:47.414 prebuffering pause 2005-09-25 17:35:47.429 prebuffering pause 2005-09-25 17:35:47.447 prebuffering pause 2005-09-25 17:35:47.766 AddInheritence? past G NOT in used or in done. dULLLAAd 2005-09-25 17:35:47.901 prebuffering pause 2005-09-25 17:35:48.000 AddInheritence? past C NOT in used or in done. dLAAAdLA 2005-09-25 17:35:48.006 AddInheritence? past C NOT in used or in done. dUALAdLL 2005-09-25 17:35:48.014 prebuffering pause 2005-09-25 17:35:48.370 AddInheritence? past H NOT in used or in done. LLLddUAA 2005-09-25 17:35:49.418 AddInheritence? past C NOT in used or in done. AdAdLLUL 2005-09-25 17:35:50.005 prebuffering pause 2005-09-25 17:35:50.006 AddInheritence? past D NOT in used or in done. AddALALA 2005-09-25 17:35:50.015 AddInheritence? past D NOT in used or in done. LddALAUL 2005-09-25 17:35:50.022 prebuffering pause 2005-09-25 17:35:50.457 AddInheritence? past B NOT in used or in done. LALLAdUd 2005-09-25 17:35:50.977 playing at normal speed from falling behind... 2005-09-25 17:35:50.988 Changing time stretch to 1.2 [mpegvideo_xvmc @ 0xb770f9d0]warning: first frame is no keyframe [mpegvideo_xvmc @ 0xb770f9d0]Past frame is a B frame in findPastSurface [mpegvideo_xvmc @ 0xb770f9d0]Past frame is a B frame in findPastSurface [mpegvideo_xvmc @ 0xb770f9d0]Past frame is a B frame in findPastSurface [mpegvideo_xvmc @ 0xb770f9d0]Past frame is a B frame in findPastSurface 2005-09-25 17:36:15.933 prebuffering pause 2005-09-25 17:36:15.933 playing slower due to falling behind... 2005-09-25 17:36:15.936 Changing time stretch to 0.96 [mpegvideo_xvmc @ 0xb770f9d0]Past frame is a B frame in findPastSurface [mpegvideo_xvmc @ 0xb770f9d0]Past frame is a B frame in findPastSurface 2005-09-25 17:36:15.950 prebuffering pause 2005-09-25 17:36:15.966 prebuffering pause 2005-09-25 17:36:17.558 playing at normal speed from falling behind... 2005-09-25 17:36:17.569 Changing time stretch to 1.2

I was watching it at 1.2x for most of the time. I tried switching to 1x, but it didn't make a difference, the log still showed tons of the above. I will attach a larger portion of the log from the frontend.

I also still have the weird problem where a forward skip actually skips backwards. There are two in the log but I can't pinpoint them. If needed I can try to reproduce and log it.

Let me know if there is any more info needed.

Attachments (1)

stutter2.log (111.4 KB) - added by tom@… 14 years ago.
Log of stuttering during playback

Download all attachments as: .zip

Change History (3)

comment:1 Changed 14 years ago by tom@…

Crap, that log came out horrible, lets try that again:

2005-09-25 17:35:46.072 prebuffering pause
2005-09-25 17:35:46.088 prebuffering pause
2005-09-25 17:35:46.684 playing at normal speed from falling behind...
2005-09-25 17:35:46.690 Changing time stretch to 1.2
2005-09-25 17:35:47.185 prebuffering pause
2005-09-25 17:35:47.186 playing slower due to falling behind...
2005-09-25 17:35:47.349 Changing time stretch to 0.96
2005-09-25 17:35:47.356 prebuffering pause
2005-09-25 17:35:47.364 prebuffering pause
2005-09-25 17:35:47.383 prebuffering pause
2005-09-25 17:35:47.397 prebuffering pause
2005-09-25 17:35:47.414 prebuffering pause
2005-09-25 17:35:47.429 prebuffering pause
2005-09-25 17:35:47.447 prebuffering pause
2005-09-25 17:35:47.766 AddInheritence past       G  NOT in used or in done. dULLLAAd
2005-09-25 17:35:47.901 prebuffering pause
2005-09-25 17:35:48.000 AddInheritence past   C      NOT in used or in done. dLAAAdLA
2005-09-25 17:35:48.006 AddInheritence past   C      NOT in used or in done. dUALAdLL
2005-09-25 17:35:48.014 prebuffering pause
2005-09-25 17:35:48.370 AddInheritence past        H NOT in used or in done. LLLddUAA
2005-09-25 17:35:49.418 AddInheritence past   C      NOT in used or in done. AdAdLLUL
2005-09-25 17:35:50.005 prebuffering pause
2005-09-25 17:35:50.006 AddInheritence past    D     NOT in used or in done. AddALALA
2005-09-25 17:35:50.015 AddInheritence past    D     NOT in used or in done. LddALAUL
2005-09-25 17:35:50.022 prebuffering pause
2005-09-25 17:35:50.457 AddInheritence past  B       NOT in used or in done. LALLAdUd
2005-09-25 17:35:50.977 playing at normal speed from falling behind...
2005-09-25 17:35:50.988 Changing time stretch to 1.2
[mpegvideo_xvmc @ 0xb770f9d0]warning: first frame is no keyframe
[mpegvideo_xvmc @ 0xb770f9d0]Past frame is a B frame in findPastSurface
[mpegvideo_xvmc @ 0xb770f9d0]Past frame is a B frame in findPastSurface
[mpegvideo_xvmc @ 0xb770f9d0]Past frame is a B frame in findPastSurface
[mpegvideo_xvmc @ 0xb770f9d0]Past frame is a B frame in findPastSurface
2005-09-25 17:36:15.933 prebuffering pause
2005-09-25 17:36:15.933 playing slower due to falling behind...
2005-09-25 17:36:15.936 Changing time stretch to 0.96
[mpegvideo_xvmc @ 0xb770f9d0]Past frame is a B frame in findPastSurface
[mpegvideo_xvmc @ 0xb770f9d0]Past frame is a B frame in findPastSurface
2005-09-25 17:36:15.950 prebuffering pause
2005-09-25 17:36:15.966 prebuffering pause
2005-09-25 17:36:17.558 playing at normal speed from falling behind...
2005-09-25 17:36:17.569 Changing time stretch to 1.2

comment:2 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: newclosed

Already was fixed.

Changed 14 years ago by tom@…

Attachment: stutter2.log added

Log of stuttering during playback

Note: See TracTickets for help on using tickets.