Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3782 closed patch (fixed)

Reassign some EIT logging output from VB_GENERAL to VB_EIT

Reported by: Nick Morrott <knowledgejunkie [at] gmail [dot] com> Owned by: Stuart Auchterlonie
Priority: minor Milestone: 0.21
Component: eit Version: head
Severity: medium Keywords: eit scanner log output
Cc: Ticket locked: no

Description

The EIT grabber currently outputs regular log output to the VB_GENERAL target which can swamp the standard log. For example:

2007-07-30 18:37:10.030 EITScanner: Now looking for EIT data on multiplex of channel 901
2007-07-30 18:38:02.532 EITScanner: Now looking for EIT data on multiplex of channel 905
2007-07-30 18:38:23.516 EITScanner: Now looking for EIT data on multiplex of channel 905
2007-07-30 18:40:15.490 EITScanner: Now looking for EIT data on multiplex of channel 905
2007-07-30 18:41:30.331 EITScanner: Now looking for EIT data on multiplex of channel 901
2007-07-30 18:41:40.007 EITScanner: Now looking for EIT data on multiplex of channel 901
2007-07-30 18:43:21.068 EITScanner: Now looking for EIT data on multiplex of channel 901
2007-07-30 18:44:56.398 EITScanner: Now looking for EIT data on multiplex of channel 905
2007-07-30 18:44:57.992 EITScanner: Now looking for EIT data on multiplex of channel 905
2007-07-30 18:46:26.536 EITScanner: Now looking for EIT data on multiplex of channel 905
2007-07-30 18:48:13.250 EITScanner: Now looking for EIT data on multiplex of channel 901
2007-07-30 18:48:25.812 EITScanner: Now looking for EIT data on multiplex of channel 901
2007-07-30 18:49:32.144 EITScanner: Now looking for EIT data on multiplex of channel 901

This patch reassigns these log messages to the VB_EIT target to give users control over whether to see this output by specifying the eit log target.

Attachments (1)

3782-reassign-eit-log-output.diff (1.8 KB) - added by Nick Morrott <knowledgejunkie [at] gmail [dot] com> 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by Nick Morrott <knowledgejunkie [at] gmail [dot] com>

comment:1 Changed 12 years ago by Stuart Auchterlonie

Component: mythtveit
Milestone: unknown0.21
Owner: changed from Isaac Richards to Stuart Auchterlonie

comment:2 Changed 12 years ago by Stuart Auchterlonie

Resolution: fixed
Status: newclosed

(In [14093]) Closes #3782. Change some EIT logging from VB_IMPORTANT to VB_EIT

Original patch by Nick Morrott, many thanks.

In addition I changed EITHelper to move the localtime offset to VB_EIT

comment:3 Changed 12 years ago by Janne Grunau

(In [14406]) Refs #3782. reapply [14093] since it got reverted by the mythtv-vid merge

caused by a type in the merge message [14088]

Note: See TracTickets for help on using tickets.