Opened 13 years ago

Closed 12 years ago

#3787 closed enhancement (fixed)

Add DVB DiSEqC switch address selection

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: DiSEqC switch address
Cc: Ticket locked: no

Description

The following patch adds addressing ability to switches under DVB DiSEqC control. This allows nesting of unlike switches (Such as a standard 4-way switch [address 0x10] attached to a DishPro? LNB [address 0x11]).

There is a database update with this implementation as we need to add a "address" field to the "diseqc_tree" table to hold the individual address values for each switch. During the database update, the most common address value for switches (0x10) will be placed in any switch entries found in order to retain current user defined DiSEqC setups.

Note: There is an outstanding bug (Ticket #3529 and possibly #3255) that prevents the full effective use of this patch. The enclosed patch does not make the problem worse, but the issue is more pronounced when you have multiple DiSEqC devices attached.

Attachments (1)

diseqc_address.diff (8.3 KB) - added by anonymous 13 years ago.

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by anonymous

Attachment: diseqc_address.diff added

comment:1 Changed 13 years ago by danielk

Owner: changed from Isaac Richards to danielk
Version: unknownhead

comment:2 Changed 12 years ago by Dibblah

Status: newassigned

comment:3 Changed 12 years ago by danielk

Resolution: fixed
Status: assignedclosed

(In [19439]) Fixes #3787. Allow multiple DiSEqC switches in a satellite setup.

Note: See TracTickets for help on using tickets.