Opened 12 years ago

Closed 11 years ago

#3792 closed defect (invalid)

MyhMusic: sporadic visualizer crash

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: 0.21
Component: mythmusic Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi,

MythMusic r14140 (trunk) crashes on me sporadically. I set it to enter visualisation mode after being idle for 15s. Sometimes, I will only get a blank screen. When I press a key in this screen, e.g. right arrow, the frontend will segfault on me. It does not happen when using the 'blank' visualizer (the one you get when you hit "5"). Visualizers I'm using: Goom, AlbumArt?, BumpScope?, MonoScope?, Squares, StereoScope?, Synaesthesia, LibVisual?-projectm, Spectrum. Backtrace is attached.

Attachments (2)

gdb.txt (13.9 KB) - added by laga+mythtv@… 12 years ago.
Backtrace
gdb.2.txt (21.2 KB) - added by Simon Kenyon <simon@…> 12 years ago.
backtrace of crash when changing visualisation

Download all attachments as: .zip

Change History (19)

Changed 12 years ago by laga+mythtv@…

Attachment: gdb.txt added

Backtrace

comment:1 Changed 12 years ago by laga+mythtv@…

This was reported by me: laga+mythtv@…

comment:2 Changed 12 years ago by stuartm

Milestone: unknown0.21
Owner: changed from Isaac Richards to stuartm
Version: unknownhead

comment:3 Changed 12 years ago by skd5aner@…

Stuart - I also see vizualizations in mythmusic cause a segfault, but it's slightly different than what the OP stated.

Here's the situation. If you think it warrants a different ticket, please let me know. Also, I'm recalling this from memory. Basically I have a few myth visualizations and libvisualizations. I select several from a list. No matter which ones I select (or order), it segfaults after I bring up the visualizations and get to the sixth visualization. I doesn't matter which one that is, nor does the order matter, it's always the sixth (I think it was six).

Anyway, I'd be happy to try to get some logs behind this sometime soon, but I saw this ticket and thought it might be related. I just hadn't gotten around to submitting one myself since I don't use mythmusic that often and the workaround is to just have less than the number of visualizations that cause the segfault.

comment:4 Changed 12 years ago by ChristiaanX

Just another 'me too' - I get a segfault with the visualisations - and also after 6 changes. My fix was to turn off the visualisations completely, rather than risking a crash. Running latest SVN trunk on FC6

comment:5 Changed 12 years ago by paulh

(In [14215]) Make sure we have a valid visualizer pointer before sending key presses to it.

Refs #3792.

comment:6 Changed 12 years ago by paulh

I cannot reproduce this at all. The fix I just commited is based on the BT attached to this ticket and just ensures we have a valid visualizer pointer before sending keypresses to it. There is a small amount of time during the transition from one vis to another where the pointer may be NULL.

laga it looks like it should fix the original segfault you had. As for the other I really don't know you'll have to try and see.

comment:7 Changed 12 years ago by paulh

Component: mythtvmythmusic

comment:8 Changed 12 years ago by anonymous

I see a visualizer crash in mythmusic, too. It is only related to the plugins synaesthesia and gforce from the libvisual package. Since the libvisual version didn't change I suggest the problem is related to mythtv. These plugins work for me: Goo, Jess, Jakdaw, Projectm, Gears

comment:9 Changed 12 years ago by stuartm

Owner: changed from stuartm to Isaac Richards

comment:10 Changed 12 years ago by stuartm

Status: newinfoneeded_new

Can we have some more backtraces from people who are seeing this issue still? I believe the original problem has been fixed.

comment:11 Changed 12 years ago by skd5aner@…

Stuart - I'm not the OP, but recently the crashes have went away for me since I've upgraded both my distro (Ubuntu Gusty Gibbon) and to latest SVN. I have a feeling it was a combination of the two that fixed the issues where visualizations were segfaulting the frontend after skipping to the ~6'th visualization. I can tell you that I'm pretty sure that #14215 did not solve the problem for me. Unfortunantly, too much changed in my environment to narrow down root cause.

comment:12 Changed 12 years ago by stuartm

There is a known issue with some versions of libvisual which I suspect to be the cause of visualiser related segfaults, we just need backtraces to prove it so that the tickets can be closed. Since the problems are with libvisual and not mythtv, they need to be fixed upstream.

comment:13 Changed 12 years ago by Simon Kenyon <simon@…>

mythfrontend crashes (in mythmusic) if you cycle through the visualisers. to make sure that it was not libvisual i removed all of those from the list of visualisations.

i'm attaching a backtrace from an AMD64 system running gentoo and svn 15127 from the 11th december.

Changed 12 years ago by Simon Kenyon <simon@…>

Attachment: gdb.2.txt added

backtrace of crash when changing visualisation

comment:14 Changed 12 years ago by Stuart Auchterlonie

Looks like malloc is raising an abort(). Possibly an Out Of Memory Condition with the visualizers?

Stuart A

comment:15 in reply to:  13 Changed 12 years ago by skd5aner@…

Replying to Simon Kenyon <simon@koala.ie>:

mythfrontend crashes (in mythmusic) if you cycle through the visualisers. to make sure that it was not libvisual i removed all of those from the list of visualisations.

i'm attaching a backtrace from an AMD64 system running gentoo and svn 15127 from the 11th december.

What I was seeing was extremely similiar (if not exact) to what Simon described. However, after my latest SVN/Distro upgrade, I no longer see the issue. Might be a fluke too?

Either way - I think these two tickets could probably be linked: http://svn.mythtv.org/trac/ticket/3836

I posted my original GDB to 3836.

comment:16 in reply to:  13 Changed 12 years ago by paulh

Status: infoneeded_newnew

Replying to Simon Kenyon <simon@koala.ie>:

mythfrontend crashes (in mythmusic) if you cycle through the visualisers. to make sure that it was not libvisual i removed all of those from the list of visualisations.

i'm attaching a backtrace from an AMD64 system running gentoo and svn 15127 from the 11th december.

Looks like libfftw3 is involved with your crash. Which version of fftw are you using? I'm using 3.0.1-r2 with no problems.

comment:17 Changed 11 years ago by danielk

Resolution: invalid
Status: newclosed

Looks like an libfftw3 memory bug which has been fixed upstream.

Note: See TracTickets for help on using tickets.