Opened 12 years ago

Closed 12 years ago

#3802 closed defect (fixed)

autoexpire list does not show host, not good on multiple backends where recording reside in different locations.

Reported by: Chuck Peters <chuck.peters+mythbug@…> Owned by: cpinkham
Priority: major Milestone: unknown
Component: mythtv Version: 0.20-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

With two backends where recordings are stored in two places the autoexpire list is not accurate, it does not show which host the recoding resides on.

I have two backends, the master backend has two tuners and the slave has one. The master disk space is often near capacity and I can't easily determine which recording will be deleted first since the autoexpire list is not showing which host has the recording.

I have a script (bash and perl) which helps somewhat, but it isn't completely accurate about the autoexpire list order yet. This would be so easy if I could mythbackend --printexpire | grep hostname. Better yet add a host option to the --printexpire, ie mythbackend --printexpire --host $hostname

mythweb doesn't seem to have a way to list just the programs in the autoexpire list, it would be nice if it did. And it would be very helpful if it listed the host of the recording.

Change History (3)

comment:1 Changed 12 years ago by Nick Morrott <<knowledgejunkie [at] gmail [dot] com>>

The auto-expirer will also try to delete recordings located on unconnected backends and then write errors to the logfile.

comment:2 Changed 12 years ago by cpinkham

Owner: changed from Isaac Richards to cpinkham

comment:3 Changed 12 years ago by cpinkham

Resolution: fixed
Status: newclosed

(In [14547]) Allow mythbackend's --printexpire command line option to take an optional hostname as an argument. If a hostname is given, only expirable recordings that were made on that particular backend are listed.

I don't see a whole lot of reason to show this information in any other place because the hostname by itself isn't all that valuable in large Myth installations that utilize multiple storage directories or share the same directories between multiple hosts. It only took a few minutes to implement this much though, so I decided to go ahead and do it.

Closes #3802.

This does not address the comment on the ticket about the Auto-Expirer trying to delete programs on non-connected backends. The current code does check to see if a backend is connected before it determines a file is expireable and tries to expire it. If this issue is reproduceable, please provide more debugging information in a separate ticket as it is unrelated to this one.

Note: See TracTickets for help on using tickets.