Opened 12 years ago

Closed 12 years ago

#3838 closed defect (invalid)

SIGSEGV starting mythfrontend

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Main screen comes up and clock is visible, no menu items. When pressing cursors, mythfrontend crashes. SVN 14205 Using debian/lenny (testing)

mythtv:~# gdb /usr/local/bin/mythfrontend GNU gdb 6.4.90-debian Copyright (C) 2006 Free Software Foundation, Inc. GDB is free software, covered by the GNU General Public License, and you are welcome to change it and/or distribute copies of it under certain conditions. Type "show copying" to see the conditions. There is absolutely no warranty for GDB. Type "show warranty" for details. This GDB was configured as "i486-linux-gnu"...(no debugging symbols found) Using host libthread_db library "/lib/i686/cmov/libthread_db.so.1".

(gdb) run Starting program: /usr/local/bin/mythfrontend (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) [Thread debugging using libthread_db enabled] [New Thread -1258264864 (LWP 1305)] Qt: gdb: -nograb added to command-line options.

Use the -dograb option to enforce grabbing.

2007-08-16 19:10:23.604 Using runtime prefix = /usr/local 2007-08-16 19:10:23.620 DPMS is active. 2007-08-16 19:10:23.763 New DB connection, total: 1 2007-08-16 19:10:23.767 Connected to database 'mythconverg' at host: localhost 2007-08-16 19:10:23.768 Total desktop dim: 1280x720, with 1 screen[s]. 2007-08-16 19:10:23.769 Using screen 0, 1280x720 at 0,0 [New Thread -1264104560 (LWP 1315)] 2007-08-16 19:10:23.966 Current Schema Version: 1195 2007-08-16 19:10:23.966 mythfrontend version: 0.20.20070717-1 www.mythtv.org 2007-08-16 19:10:23.966 Enabled verbose msgs: important general 2007-08-16 19:10:24.067 The theme (classic) needs to be updated to include a themeinfo.xml file 2007-08-16 19:10:24.068 The theme (DVR) needs to be updated to include a themeinfo.xml file 2007-08-16 19:10:24.090 The theme (oldosd) needs to be updated to include a themeinfo.xml file 2007-08-16 19:10:24.179 Total desktop dim: 1280x720, with 1 screen[s]. 2007-08-16 19:10:24.180 Using screen 0, 1280x720 at 0,0 2007-08-16 19:10:24.181 Switching to wide mode (MythCenter?-wide) 2007-08-16 19:10:24.364 Using the OpenGL painter [New Thread -1279620208 (LWP 1319)] 2007-08-16 19:10:24.367 lirc init success using configuration file: /root/.mythtv/lircrc [New Thread -1288012912 (LWP 1320)] 2007-08-16 19:10:24.368 Joystick disabled. [Thread -1288012912 (LWP 1320) exited] 2007-08-16 19:10:24.890 Loading from: /usr/local/share/mythtv/themes/MythCenter-wide/base.xml 2007-08-16 19:10:24.895 Loading from: /usr/local/share/mythtv/themes/default/base.xml 2007-08-16 19:10:24.932 Registering Internal as a media playback plugin. /usr/local/lib/mythtv/plugins/libmythdvd.so: undefined symbol: _ZN18ConfigurationGroup6byNameE7QString 2007-08-16 19:10:25.231 MythPlugin::init() dlerror: /usr/local/lib/mythtv/plugins/libmythdvd.so: undefined symbol: _ZN18ConfigurationGroup6byNameE7QString 2007-08-16 19:10:25.231 Unable to initialize plugin 'mythdvd'. 2007-08-16 19:10:25.291 MonitorRegisterExtensions?(0x100, gif,jpg,png) 2007-08-16 19:10:25.423 Using NV NPOT texture extension 2007-08-16 19:10:25.468 MythMusic adding CD-Writer: 1,0,0 -- CD/DVDW SH-W163A 2007-08-16 19:10:25.606 MonitorRegisterExtensions?(0x40, ogg,mp3,aac,flac) [New Thread -1288012912 (LWP 1338)] [New Thread -1318552688 (LWP 1339)] Failed to find network interface eth0 SIP listening on IP Address :5060 NAT address SIP: Cannot register; proxy, username or password not set Destroying SipFsm? object [Thread -1318552688 (LWP 1339) exited] [Thread -1288012912 (LWP 1338) exited] 2007-08-16 19:10:26.335 Starting media monitor. [New Thread -1288012912 (LWP 1342)] 2007-08-16 19:10:26.741 MythThemedMenuPrivate?: Must have room for at least 1 column of buttons 2007-08-16 19:10:27.691 Detected MediaType? MEDIATYPE_DVD 2007-08-16 19:10:27.691 Media status changed... (MEDIATYPE_DVD, MEDIASTAT_NOTMOUNTED -> MEDIASTAT_USEABLE)

Program received signal SIGSEGV, Segmentation fault. [Switching to Thread -1258264864 (LWP 1305)] 0xb6addadc in MythThemedMenuPrivate::checkScrollArrows (this=0x8379828)

at myththemedmenu.cpp:1833

1833 if (!buttonRows.front().visible) Current language: auto; currently c++ (gdb) bt #0 0xb6addadc in MythThemedMenuPrivate::checkScrollArrows (this=0x8379828)

at myththemedmenu.cpp:1833

#1 0xb6ade14b in MythThemedMenuPrivate::makeRowVisible (this=0x8379828,

newrow=6881388, oldrow=6881388) at myththemedmenu.cpp:1823

#2 0xb6aedf25 in MythThemedMenuPrivate::keyHandler (this=0x8379828,

actions=@0xbfb5e608, fullexit=true) at myththemedmenu.cpp:2004

#3 0xb6aee3df in MythThemedMenuPrivate::keyPressHandler (this=0x8379828,

e=0xbfb5ec40) at myththemedmenu.cpp:1869

#4 0xb6aee471 in MythThemedMenu::keyPressEvent (this=0x8379558, e=0xbfb5ec40)

at myththemedmenu.cpp:2385

#5 0xb6aa35e6 in MythMainWindow::eventFilter (this=0x82da350, e=0xbfb5ec40)

at mythmainwindow.cpp:1114

#6 0xb62ce2d0 in QObject::activate_filters () from /usr/lib/libqt-mt.so.3 #7 0xb62ce34e in QObject::event () from /usr/lib/libqt-mt.so.3 #8 0xb6305bd2 in QWidget::event () from /usr/lib/libqt-mt.so.3 #9 0xb62664e0 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3 #10 0xb62684b0 in QApplication::notify () from /usr/lib/libqt-mt.so.3 #11 0xb61f9609 in QApplication::sendSpontaneousEvent ()

from /usr/lib/libqt-mt.so.3

#12 0xb61ea690 in QETWidget::translateKeyEvent () from /usr/lib/libqt-mt.so.3 #13 0xb61f674e in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3 #14 0xb620cfb8 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3 #15 0xb6280be6 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3 ---Type <return> to continue, or q <return> to quit--- #16 0xb62809f6 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3 #17 0xb6268089 in QApplication::exec () from /usr/lib/libqt-mt.so.3 #18 0x080674e5 in ?? () #19 0xb5b10030 in libc_start_main () from /lib/i686/cmov/libc.so.6 #20 0x0805d241 in ?? () (gdb)

Change History (2)

comment:1 Changed 12 years ago by anonymous

Problem disappeared after clearing theme cache and changing theme via mythweb.

Sorry about the fuss.

comment:2 Changed 12 years ago by stuartm

Resolution: invalid
Status: newclosed

This problem is normally caused by a corrupt theme, reinstalling the themes normally helps.

Note: See TracTickets for help on using tickets.