Opened 12 years ago

Closed 12 years ago

#3857 closed defect (invalid)

Mythfrontend import dvd issues

Reported by: anonymous Owned by: Anduin Withers
Priority: minor Milestone: 0.21
Component: mythdvd Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using August 19, 2007 commits 14227

Import DVD has the following issues:

If you have selected all 25 segments (25 vob files), and all of them and ISO ripping method each one generates a 7gb file, which is the whole DVD. Thats 175gb

If the user selects ISO there should be no other options.

Using Perfect mode fails to rip the menu on my title, and the files are placed in the same directory instead of one directory for each DVD.

ISO rips of normal(protected) DVD are useless because the subchannel data that contains the encryption key is not copied so if you try and play the DVD its a jerky slideshow with pixelation. The ISO dump has to be augmented with a seperate file for the subchannel data in a format thats compatible with some player. Like Virtual CD by H+H software group will emulate a virtual cd/dvd drive from a file, and several file formats that supports the ability to make the sub-channel data available to the dvd playing software.

Mount and playing from linux has the same problem because "mount -t iso9660 <source> <mount point>" still does not have access to the subchannel data.

If you want a working ISO rip you need to do the rip, and then extract the vob files decrypt them and put them back. I suggest "mount -t iso9660 -o loop /path/to/file/whatever.iso <mount point>" cp <mount point>/*.vob <temp location> decrypt now you have to re-insert the files into the ISO. I have never tried it but you might be able to cp them back into mounted ISO image.

Change History (5)

comment:1 Changed 12 years ago by Anduin Withers

Resolution: invalid
Status: newclosed

Do not abuse the ticket system.

comment:2 Changed 12 years ago by anonymous

Resolution: invalid
Status: closedreopened

I have a real problem to report.

  1. ISO rips un-playable (from store bought DVD)
  2. If you select all entries, in ISO rip mode, that number of copies of DVD are made. For example if a DVD has 25 chapters, you select ISO rip for each of the 25 chapters and 25 ISO files are created each containing the whole thing.

So please enlighten me as to how I am "abusing the ticket system" so I don't repeat the same mistake twice.

Are these documented somewhere that I failed find and read or what???

comment:3 Changed 12 years ago by anonymous

Anduin is right, these aren't bugs and should be discussed on the mailing lists. If anything, it's just usability issues. However, here are some brief answers.

All you have to do is simply select ISO on any single chapter and don't select any other chapters to be ripped. This will create an ISO of the entire DVD even though the other chapters aren't explicitly selected.

Perfect mode only transcodes the main title as an MPEG2. This is so you can get the best picture quality in a single video file. If you want the menus, you have to do ISO. The other options (excellent and good) transcode to other lossy, compressed formats (like xvid).

Creating individual subdirectories is a feature, feel free to submit a patch. Until then, all files created by the import are stored in a single directory (not really that big of a deal).

I can't speak about the other stuff you mentioned in regards to the ISOs, other than to say that I haven't had any problems with the limited number of ISOs I've made and played back.

comment:4 Changed 12 years ago by anonymous

The actual DVD plays back good in WinDVD8 on my pc, and the integrated player built into mythfrontend. So the DVD is not damaged. I ripped the files off in perfect mode, and those work, but just by looking a bunch of VOB files I can't tell which one I am supposed to be playing nor in what order. Which of course is what the menu is supposed to do.

I don't know if DVD I am trying to play has slightly different encryption method or what, but when you try and play the ISO version the output is useless. One single frame is displayed for over 2 minutes at a time, and the audio continues.

I (IMHO) believe the problem is ISO contents were never decrypted, and the decryption keys are stored in a "Sub channel" on the DVD. I have no idea how or where this sub channel exists, but I know a sub channel is a option component. Several Windows based rippers have demonstrated there existance by pull data from them.

A regular ISO rip does not grab thia "sub channel" data so the DVD player can't decode it, because the decryption key are not copied. (IMHO) this is why my DVD playback is bad.

comment:5 Changed 12 years ago by Anduin Withers

Resolution: invalid
Status: reopenedclosed

This ticket can be reopened with a patch for issue B, the DVD import GUI could be much smarter.

Note: See TracTickets for help on using tickets.