Opened 14 years ago

Closed 14 years ago

#389 closed defect (invalid)

DVD Auto-detect failure

Reported by: blah@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using most up-to-date subversion checkout as of 09/27/2005.

I am getting my MythTV box setup and experimenting with all of the features and ran into a small snag. I was trying to use the auto-detect feature for CD/DVD insertion to automatically start playing a DVD. I was using the "Gone In 60 Seconds" DVD for my experiments, and for some reason it would not auto start the DVD although it was automounting). I quit the frontend and noticed the log showing MythTV was looking for a few directories to determine the CD type (/VIDEO_TS, /vcd, /svcd). I looked at my mounted DVD and the directory was actually /video_ts instead of /VIDEO_TS. Whether this was caused by something odd in the mounting process or a poorly authored DVD, I am not sure. I tried the Die Hard 3 Special Edition DVD and had the same results. I did some copy-and-paste in the source for libs/libmyth/mythcdrom.cpp and added a check for /video_ts in addition to the other three checks. Now the DVD auto-plays beautifully.

I'm not sure if any others have had this problem, but it might be useful to add the code that checked for the lower case version of the directory too. I can send a patch file if desired, but I'm sure you can figure out how I did it, if you do decide to add this to the core code.

Change History (1)

comment:1 Changed 14 years ago by Isaac Richards

Resolution: invalid
Status: newclosed

You've got the DVD set to the wrong filesystem type - it should be udf, not iso9660, IIRC.

Note: See TracTickets for help on using tickets.