Opened 12 years ago

Closed 9 years ago

#3902 closed defect (fixed)

Duplicate detection failure with two videosources and when program lengths differ

Reported by: otto at kolsi dot fi Owned by: gigem
Priority: minor Milestone: unknown
Component: MythTV - Scheduling Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have setup where I have 2 video sources. Both have all the free channels and the other has also channels that require CAM. This means that I have duplicate program info in DB, all the programs in free channels have two entries there.

I create recording rule "Record only this showing" and put dup method to only descriptions (because we don't have subtitles here). Now in normal cases everything is working well and this rule only records the desired program (althought there are sort of two different versions of it available in program table).

But if for some reason the length or end-time of one of the programs differ (e.g. is 1min shorter), then the dup checking does not work and Myth will record this one show twice using two different cards from two video sources.

If in this case the recording rule type is "Record at any time on this channel", then the dup checking works.

This should be easy for anyone with similar setup to reproduce, just go and manually edit the end time of one of the shows a bit shorter and re-schedule.

Change History (3)

comment:1 Changed 10 years ago by stuartm

Component: mythtvMythTV - Scheduling

comment:2 Changed 9 years ago by danielk

Owner: changed from Isaac Richards to gigem
Status: newassigned

comment:3 Changed 9 years ago by gigem

Resolution: fixed
Status: assignedclosed

(In [24838]) Loosen the time check in PI::IsSameTimeslot?() to not check end times. Fixes #3902.

Note: See TracTickets for help on using tickets.