Opened 12 years ago

Closed 12 years ago

#3939 closed defect (worksforme)

Channel detail page defalt date value missing

Reported by: anonymous Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: mythweb Version: 0.20
Severity: low Keywords:
Cc: Ticket locked: no

Description

if you click on a channel from the listings page you will get a error because of negative values for a date. around line 38 in ... last_time is set but if the 'date' post or get value is not set the variable is -1(false). I fixed it on my box by changing

New list date?

$_GETdate? or $_GETdate? = $_POSTdate?; if ($_GETdate?)

$_SESSIONlist_time? = unixtime(sprintf('%08d000000', $_GETdate?));

to

New list date?

$_GETdate? or $_GETdate? = $_POSTdate?; if ($_GETdate?)

$_SESSIONlist_time? = unixtime(sprintf('%08d000000', $_GETdate?));

if (!$_SESSIONlist_time?)

$_SESSIONlist_time? = unixtime(sprintf('%08d000000', date('Ymd')));

Change History (3)

comment:1 Changed 12 years ago by Rob Smith

Owner: changed from xris to Rob Smith
Status: newassigned

comment:2 Changed 12 years ago by Rob Smith

care to submit this as a patch?

comment:3 Changed 12 years ago by Rob Smith

Resolution: worksforme
Status: acceptedclosed

Can't reproduce in current branch, feel free to reopen if it still happens to you

Note: See TracTickets for help on using tickets.