Opened 12 years ago

Closed 8 years ago

#3952 closed enhancement (Won't Fix)

add support for linkage descriptors and create an osd menu entry for linked events

Reported by: anonymous Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - DVB Version: head
Severity: medium Keywords:
Cc: Stuart Auchterlonie Ticket locked: no

Description

The german provider Premiere and maybe other providers have special channels for PPV or sport events. On certified receivers you have an option key to reach these subevents like different camera perspectives in formula one events or the different movies on dynamic channels. This patch reads the linkage descriptors in the epg stream and writes the information to a special table. The Frontend reads the table when access the osd menu and insert an entry "subchannel" if the tuned channel is part of a linkage. The subchannel entry has subentries to each linked event and you can switch to all subevents from the menu. Note, that subentries were only created for events that have a valid epg entry in the program table.

At the moment I didn't like how to show the subevents. I'd like to have some more information per event, like start or endtime, but I don't know how to realize it. Therefore a double line menu entry is needed. Maybe the best way were to put the info in an own treemenu that fills the screen horizontal. Comments are welcome.

This patch is only tested with the german provider Premiere. Please provide me infos how it works on other providers. Maybe the store function must be restrict to a special linkage type. Premiere uses user_defined 0xb0 as type.

Attachments (9)

linkage_backend.diff (3.9 KB) - added by Wolfgang <mythtv@…> 12 years ago.
backend patch for the linkage support
linkage_frontend.diff (2.6 KB) - added by Wolfgang <mythtv@…> 12 years ago.
frontend patch for linkage support
linkage.sql (491 bytes) - added by Wolfgang <mythtv@…> 12 years ago.
sql for creating linkage table
linkage_frontend_menu.diff (6.4 KB) - added by Wolfgang <mythtv@…> 12 years ago.
alternative method, the linkage has its own menu accessed by "F1" key as default
linkage_osd_myththemes.diff (4.2 KB) - added by Wolfgang <mythtv@…> 12 years ago.
osd link menu entries for all themes
linkage_backend.2.diff (5.1 KB) - added by Wolfgang <mythtv@…> 12 years ago.
Replaced backend patch with improved version
linkage_backend.3.diff (4.7 KB) - added by Wolfgang <mythtv@…> 12 years ago.
new backend version
linkage_frontend_menu.2.diff (6.8 KB) - added by Wolfgang <mythtv@…> 12 years ago.
new frontend patch
linkage.2.sql (263 bytes) - added by Wolfgang <mythtv@…> 12 years ago.
new sql file

Download all attachments as: .zip

Change History (18)

Changed 12 years ago by Wolfgang <mythtv@…>

Attachment: linkage_backend.diff added

backend patch for the linkage support

Changed 12 years ago by Wolfgang <mythtv@…>

Attachment: linkage_frontend.diff added

frontend patch for linkage support

Changed 12 years ago by Wolfgang <mythtv@…>

Attachment: linkage.sql added

sql for creating linkage table

comment:1 Changed 12 years ago by Janne Grunau

Owner: changed from Isaac Richards to Janne Grunau

Changed 12 years ago by Wolfgang <mythtv@…>

Attachment: linkage_frontend_menu.diff added

alternative method, the linkage has its own menu accessed by "F1" key as default

Changed 12 years ago by Wolfgang <mythtv@…>

Attachment: linkage_osd_myththemes.diff added

osd link menu entries for all themes

comment:2 Changed 12 years ago by Wolfgang <mythtv@…>

The last two patches are an alternative for the frontend.

Now there is an own menu for the subevents reachable by pressing F1.

Changed 12 years ago by Wolfgang <mythtv@…>

Attachment: linkage_backend.2.diff added

Replaced backend patch with improved version

comment:3 Changed 12 years ago by Wolfgang <mythtv@…>

Added new backend patch.

Storage function only called if linkages exist and old linkages are deleted if channel event has no new one (I don't know if this can be happen, on my Provider Premier the linkages are present all the time)

Changed 12 years ago by Wolfgang <mythtv@…>

Attachment: linkage_backend.3.diff added

new backend version

Changed 12 years ago by Wolfgang <mythtv@…>

new frontend patch

Changed 12 years ago by Wolfgang <mythtv@…>

Attachment: linkage.2.sql added

new sql file

comment:4 Changed 12 years ago by Wolfgang <mythtv@…>

Attached new versions.

Changes:

call only one insert statement per portal chanid
sort linkages as they come from the provider

comment:5 Changed 12 years ago by danielk

Version: unknownhead

comment:6 Changed 12 years ago by Stuart Auchterlonie

Cc: Stuart Auchterlonie added

comment:7 Changed 11 years ago by Dibblah

Status: newassigned

comment:8 Changed 10 years ago by stuartm

Component: mythtvMythTV - DVB

comment:9 Changed 8 years ago by robertm

Resolution: Won't Fix
Status: assignedclosed

Closing another ticket as hopelessly old. This is not the ticket submitter's fault, but as it's an enhancement and not a bug, the only way I can think of to elicit action from someone is to closing it. It's been four years. If a dev intends to look at it, it's time. If the user wants to provide an updated patch to smack us in the face with, that's fine too.

Note: See TracTickets for help on using tickets.