Opened 12 years ago

Closed 12 years ago

#3955 closed defect (fixed)

Segfault on search listing on Title

Reported by: Robin Gilks <g8ecj@…> Owned by: stuartm
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

-v all log and gdb backtrace attached.

Attachments (2)

myth-trace.bz2 (4.1 KB) - added by Robin Gilks <g8ecj@…> 12 years ago.
myth.log.bz2 (9.1 KB) - added by Robin Gilks <g8ecj@…> 12 years ago.

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by Robin Gilks <g8ecj@…>

Attachment: myth-trace.bz2 added

Changed 12 years ago by Robin Gilks <g8ecj@…>

Attachment: myth.log.bz2 added

comment:1 Changed 12 years ago by Joe Ripley <vitaminjoe@…>

I can confirm that this happens this happens to me as well. It is not limited to just the Schedule Recordings -> Search Words -> Title screen. Any of the 'Search Words' options will cause the segfault.

The problem originates in the ProgLister::paintEvent() function (as the backtrace indicates: proglist.cpp line 314).

It seems there's some common error in ProgLister?. Any time it tries to paint itself, the program segfaults...

I'll keep investigating...

-- Joe Ripley vitaminjoe@…

comment:2 Changed 12 years ago by stuartm

Milestone: unknown0.21
Owner: changed from Isaac Richards to stuartm
Status: newassigned

comment:3 Changed 12 years ago by stuartm

Status: assignedstarted

comment:4 Changed 12 years ago by stuartm

Status: startedinfoneeded

I cannot reproduce this segfault, could you provide more detail about what you are doing when it occurs and a backtrace against current Trunk?

The line numbers in the existing backtrace don't match up with trunk so I can only guess that it happens when we create a copy of the painter which doesn't help much.

I'd also be interested to know if there are any other factors which you both have in common, such as distro, packaged or built from source and which --version you are using.

comment:5 Changed 12 years ago by stuartm

Status: infoneededassigned

What theme you are using might also be relevant.

comment:6 Changed 12 years ago by stuartm

Status: assignedinfoneeded

comment:7 Changed 12 years ago by Robin Gilks <g8ecj@…>

Whatever the problem was, it went away by itself as I can't reproduce it either in r15216.

Lots of uPNP crashes I CAN reproduce however :-(

comment:8 Changed 12 years ago by stuartm

Resolution: fixed
Status: infoneededclosed

Looks like this got fixed by an earlier changeset but I've no idea which one.

Note: See TracTickets for help on using tickets.