Opened 12 years ago

Closed 12 years ago

#3967 closed defect (duplicate)

segfault on dvb channel scan

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: unknown
Component: dvb Version: 0.20-fixes
Severity: high Keywords:
Cc: Ticket locked: no

Description

mythtv-setup segfaults on dvb channel scan. When it doesn't segfault, it creates bogus channels (0_188, 1_88, and so on.)

Attachments (3)

myth.txt (241.2 KB) - added by yan@… 12 years ago.
gdb.txt (17.0 KB) - added by yan@… 12 years ago.
gdb.2.txt (13.2 KB) - added by yan@… 12 years ago.

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by yan@…

Attachment: myth.txt added

Changed 12 years ago by yan@…

Attachment: gdb.txt added

comment:1 Changed 12 years ago by danielk

Resolution: duplicate
Status: newclosed

Duplicate of #2909.

comment:2 Changed 12 years ago by yan@…

Resolution: duplicate
Status: closedreopened

No joy. Rebuilt myth from SVN, got segfault in the exact same place (channel 17 DVB scan).

comment:3 Changed 12 years ago by danielk

Resolution: duplicate
Status: reopenedclosed

Yan,

The fix has only been applied to svn trunk, not 0.20-fixes. If you managed to reproduce this in the trunk please post the backtrace you got, Attach it to the original ticket, #2909.

Changed 12 years ago by yan@…

Attachment: gdb.2.txt added
Note: See TracTickets for help on using tickets.