Opened 12 years ago

Closed 12 years ago

#3974 closed defect (fixed)

latest svn not playing h264 720p50

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After the vid merge, mythtv in unable to play recordings from SVT HD errors from debug playback.

2007-09-16 11:12:52.515 AFD: Opened codec 0x82f6120, id(MP3) type(Audio) 2007-09-16 11:12:52.517 AFD: Opened codec 0x82f5830, id(H264) type(Video) 2007-09-16 11:12:52.518 AFD: Opened codec 0x83031d0, id(AC3) type(Audio) 2007-09-16 11:12:52.518 AFD: Opened codec 0x82f8720, id(DVB_SUBTITLE) type(Subtitle) 2007-09-16 11:12:52.611 [h264 @ 0xb74040c8]left block unavailable for requested intra mode at 0 21 2007-09-16 11:12:52.612 [h264 @ 0xb74040c8]error while decoding MB 0 21, bytestream (17329) 2007-09-16 11:12:52.624 [h264 @ 0xb74040c8]left block unavailable for requested intra4x4 mode -1 at 0 30 2007-09-16 11:12:52.624 [h264 @ 0xb74040c8]error while decoding MB 0 30, bytestream (4209) 2007-09-16 11:12:52.631 [h264 @ 0xb74040c8]cabac decode of qscale diff failed at 34 35 2007-09-16 11:12:52.631 [h264 @ 0xb74040c8]error while decoding MB 34 35, bytestream (24000) 2007-09-16 11:12:52.674 [h264 @ 0xb74040c8]error while decoding MB 12 20, bytestream (-14) 2007-09-16 11:12:52.743 [h264 @ 0xb74040c8]error while decoding MB 75 6, bytestr

Is this to be expected? i have tried different options in the playback settings but nothing seems to decode it.

before the "standard" ok

Change History (6)

comment:1 Changed 12 years ago by posting@…

Hi,

I can confirm that problem. It happens here with x264/AVC encoded files. No matter if the source is a PAL or NTSC (after inverse telecine to 24p) DVD.

One more observation:

CPU usage is at about 44% on my C7 which is about right (about the same number I had seen before when playback still worked).

Any more info I can provide ?

comment:2 Changed 12 years ago by jyrki.n@…

I'm also out of luck playing h264 720p50. I'm using stable 20.2 though, but I guess we need ffmpeg resync to be able to play them in mythtv. When I playback the stream with latest mplayer (svn) it works with about 70% load on a AMD 64 X2 4200+ processor (you also need '-lavdopts threads=2' to utilize codec and cpu)

comment:3 Changed 12 years ago by anonymous

Well for me with a core2 duo at 3 ghz and a 8600 GTS it played quite ok before the vid-merge, now i just get prebuffer pauses and black video and after a while it gives up.

comment:4 Changed 12 years ago by anonymous

With SVN 14599 it plays fine again using XV Good work who ever fixed this :)

comment:5 Changed 12 years ago by Joe Ripley <vitaminjoe@…>

Not sure if this is related or not, but I had this problem as well. I think it was fixed in changeset [14599]. After I moved to a SVN release 14606 playback of H.264 videos with the Internal player started working.

-- Joe Ripley vitaminjoe@…

comment:6 Changed 12 years ago by danielk

Resolution: fixed
Status: newclosed

This was probably fixed by [14599]. I just wasn't aware of this ticket.

Note: See TracTickets for help on using tickets.