Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3984 closed defect (fixed)

mythbackend constantly crashing (SVN trunk)

Reported by: anonymous Owned by: Isaac Richards
Priority: critical Milestone: unknown
Component: mythtv Version: head
Severity: high Keywords:
Cc: Ticket locked: no

Description

I'm running the latest mythtv from SVN on my Ubuntu 7.04 (Feisty) x86_64 box. And lately (sometime in the past few weeks) I haven't been able to get mythbackend to run consistently. I can crash it simply by choosing to Watch TV for a few minutes, going back to the main menu, and then when I select Watch TV again, mythbackend crashes. I'm attaching myth.log and also the gdb output I generated by following the procedure written about here: http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

Attachments (3)

gdb.txt.crash (28.0 KB) - added by johnfivealive@… 12 years ago.
GDB Debug Log
myth.log.crash (14.2 KB) - added by johnfivealive@… 12 years ago.
Log of Crashed mythbackend Debug Run
gdb.20070927.txt (25.8 KB) - added by xris 12 years ago.
crash from revision 14542. Seemed to crash during a recording (firewire, came out to zero bytes).

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by johnfivealive@…

Attachment: gdb.txt.crash added

GDB Debug Log

Changed 12 years ago by johnfivealive@…

Attachment: myth.log.crash added

Log of Crashed mythbackend Debug Run

comment:1 Changed 12 years ago by anonymous

I am also having this problem running latest SVN on gentoo stable.

Changed 12 years ago by xris

Attachment: gdb.20070927.txt added

crash from revision 14542. Seemed to crash during a recording (firewire, came out to zero bytes).

comment:2 Changed 12 years ago by anonymous

I originally reported this bug and I'd like to report that as of compiling and installing MythTV from SVN revision 14648, mythbackend is no longer crashing. Was this bug deliberately fixed? If so, I'm curious to know what the solution was. If it starts crashing again over the next few days (or in newer SVN revs.), I'll report back here.

comment:3 Changed 12 years ago by anonymous

Me again, I think I spoke too soon, the crashing has come back, though it seems less frequent now.

comment:4 Changed 12 years ago by johnfivealive@…

The backend crash is still happening periodically, here's the message that appears in the syslog when it crashes:

mythbackend[12166] general protection rip:2b454a7cf584 rsp:4a016b88 error:0

comment:5 Changed 12 years ago by illesNOSPAMatG__MAIL.cOM

I've experienced this same phenomenon on my ubuntu gutsy with mythbuntu + mythtv 0.20.2. I managed to locate the cause of it!

It seems that when I use RTJpeg for the TV record and set it to a quality higher than around 210-220+ it begins to crash when recording is starting with general protection message (kernel 64 bit catches the mythtv segfault). So if I set quality of RTJpeg around 170 I do not experience the problem.

System: AMD 64 x2, Gutsy AMD64bit, kernel 2.6.23.8 custom and with original gutsy kernel too.

comment:6 Changed 12 years ago by johnfivealive@…

As the above commenter suggests, the problem is possibly with the rtjpeg/mpeg2 codec (ffmpeg?). I switched my Default and Live TV encoders to MPEG4 and the backend has been stable ever since (hasn't crashed once), though I saw the frontend crash a couple times now for reasons which I can't explain.

So, I guess there must be some bug in ffmpeg that only gets triggered on systems running an 64-bit OS. Or it could be something else, but the problem most likely stems from some bug with mpeg2 processing on AMD 64 Linux.

I should mention that I reverted back to the latest version of MythTV as packaged by Ubuntu Gutsy, but I was experiencing this same bug with this older version. I'm assuming the bug still exists in SVN trunk, though I have yet to verify this.

comment:7 Changed 12 years ago by danielk

Resolution: fixed
Status: newclosed

This was fixed a couple weeks ago in [15470].

comment:8 Changed 12 years ago by illespal

Hope it's so although I cannot really see the relation yet between these too things if it isn't a thing about it's trying to initialize recording twice because of problems with the codec, I will test it if the new package comes out.

Note: See TracTickets for help on using tickets.