Opened 12 years ago

Closed 12 years ago

#3989 closed patch (duplicate)

build problem under gentoo

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi all,

after upgrading my gentoo system to the latest version the trunk and 0.20-fixes versions of mythtv throw this error when build

cd programs && make -f Makefile make[1]: Entering directory `/home/mythtv/mythtv_build/mythtv/programs' cd mythtv && make -f Makefile make[2]: Entering directory `/home/mythtv/mythtv_build/mythtv/programs/mythtv' ccache g++ -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -o mythtv main.o -L/usr/qt/3/lib -L../../libs/libmyth -L../../libs/libmythtv -L../../libs/libavutil -L../../libs/libavcodec -L../../libs/libavformat -L../../libs/libmythfreemheg -L../../libs/libmythui -L../../libs/libmythupnp -L../../libs/libmythlivemedia -lmythtv-0.20 -lmythavformat-0.20 -lmythavutil-0.20 -lmythavcodec-0.20 -lmythfreemheg-0.20 -lmythupnp-0.20 -lmythlivemedia-0.20 -lmyth-0.20 -lmythui-0.20 -lfreetype -lz -lmp3lame -lasound -L/usr/X11R6/lib -lXinerama -lXv -lXxf86vm -lXrandr -lXvMCW -lXvMC -lqt-mt -lGLU -lGL -lXmu -lXext -lX11 -lm -lpthread ../../libs/libmythtv/libmythtv-0.20.so: undefined reference to `MHSetLogging(_IO_FILE*, unsigned int)' ../../libs/libmythtv/libmythtv-0.20.so: undefined reference to `MHCreateEngine(MHContext*)' collect2: ld gab 1 als Ende-Status zurück

after much help from joe ripley on the users mailing list and searching around i found a patch from gentoo that adds a few more entrys to the library search pathes in the *.pro files. i attach a copy from the patch that applys clean to the latest svn trunk.

This seems not realy to be a bug in mythtv, but it can easy fixed here so i decided to open this ticket.

Greets and keep up good work!! Alex

Attachments (1)

mythtv-trunk-as-needed.patch (4.2 KB) - added by babyfly@… 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by babyfly@…

comment:1 in reply to:  description Changed 12 years ago by anonymous

Trac forget my email :) babyfly@…

comment:2 Changed 12 years ago by chewi@…

Thanks for this!

comment:3 Changed 12 years ago by paulh

Resolution: duplicate
Status: newclosed

Duplicate of #2402

Incidentally I also use Gentoo and Myth compiles fine for me. Although I'm still using binutils 2.16.1-r3. I think the lesson here is don't update thing's if it ain't broke ;-)

Note: See TracTickets for help on using tickets.