Opened 12 years ago

Closed 12 years ago

#3995 closed patch (invalid)

backend segfault (with bt) when deleting in-progress zero-byte recordings

Reported by: xris Owned by: danielk
Priority: critical Milestone: 0.22
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Backend keeps crashing during/after recordings and/or while messing with files via mythweb.

Attachments (4)

gdb.txt (21.8 KB) - added by xris 12 years ago.
gdb.20070927.txt (25.8 KB) - added by xris 12 years ago.
gdb.20070930.txt (23.9 KB) - added by xris 12 years ago.
3995-v1.patch (2.9 KB) - added by danielk 12 years ago.
Possible fix

Download all attachments as: .zip

Change History (16)

comment:1 Changed 12 years ago by xris

Priority: majorcritical
Summary: backend crash (with bt), possibly storage-group relatedbackend segfault (with bt) when deleting in-progress zero-byte recordings

Still happening to me with [14935]... The crashes are pretty easily replicated now. If I get an in-progress zero-byte recording (see [3872]), the backend segfaults immediately when I try to delete or delete/rerecord the recording (I have the "deleted recgroup" stuff turned on, if that makes a difference)

comment:2 Changed 12 years ago by xris

make that #3872

comment:3 Changed 12 years ago by stuartm

Milestone: unknown0.21

comment:4 Changed 12 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:5 Changed 12 years ago by danielk

Status: assignedinfoneeded

We're going to need a backtrace with debugging symbols for this to be fixable...

Changed 12 years ago by xris

Attachment: gdb.txt added

Changed 12 years ago by xris

Attachment: gdb.20070927.txt added

Changed 12 years ago by xris

Attachment: gdb.20070930.txt added

comment:6 Changed 12 years ago by xris

Status: infoneededassigned

Attached what I have. There is an arch problem with debug packages in fedora, so a bunch of symbols are missing.

This problem seems to have gotten better recently. Not sure if it's gone for good or not, but it's definitely more stable in the last week or two.

Changed 12 years ago by danielk

Attachment: 3995-v1.patch added

Possible fix

comment:7 Changed 12 years ago by danielk

Chris, can you tell me if the patch I just attached helps?

comment:8 Changed 12 years ago by danielk

Type: defectpatch

comment:9 Changed 12 years ago by xris

As you already know (but for the record here), the patch has an infinite loop in it that makes it useless.

comment:10 Changed 12 years ago by danielk

Status: assignedinfoneeded

xris, I'm going to need a backtrace with the patch applied to figure out what the problem is. (run it in gdb, wait for it to deadlock, then hit Ctrl-C and run "thread apply all bt")

comment:11 Changed 12 years ago by danielk

Milestone: 0.210.22

moving info_needed to 0.22

comment:12 Changed 12 years ago by danielk

Resolution: invalid
Status: infoneededclosed

info needed not provided in 6 weeks, closing.

Note: See TracTickets for help on using tickets.