Opened 12 years ago

Closed 12 years ago

#3997 closed defect (invalid)

Via XvMC not working after mythtv-vid merge

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords: mythtv-vid xvmc via
Cc: Ticket locked: no

Description

I'm using SVN 14510 with a Via EX10000EG. Openchrome drivers. All was working fine before this last SVN upgrade (which was pre-mythtv-vid merge). I went in and set up a new video profile, and to make things simple, created one which just used Via XVMC all of the time. This box only watches MPEG2 recordings that are 720x480, so this should be fine. Mythfrontend shows this error: <datetime> VideoOutputXv?: XvMC Adaptor Name: 'XV_SWOV' Unable to create XvMC surface CPU utilization then goes to about 96%. Anything I did wrong here? What other debugging info is needed?

Attachments (2)

xvmc-vld-whitout-xv-blit.log (18.9 KB) - added by l-case@… 12 years ago.
xvmc-vld-xv-blit.log (19.6 KB) - added by l-case@… 12 years ago.

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by l-case@…

Changed 12 years ago by l-case@…

Attachment: xvmc-vld-xv-blit.log added

comment:1 Changed 12 years ago by l-case@…

I have here also tried to get it running, here are my profiles with logs:

xvmc-vld-xv-blit.log
+----------------+-----------+--------------------+-----------+
| profilegroupid | profileid | value              | data      |
+----------------+



-----------+--------------------+-----------+
|              4 |        13 | pref_cmp0          | > 0 0     |
|              4 |        13 | pref_decoder       | xvmc-vld  |
|              4 |        13 | pref_deint0        | none      |
|              4 |        13 | pref_deint1        | none      |
|              4 |        13 | pref_filters       | xv-blit   |
|              4 |        13 | pref_osdfade       | 0         |
|              4 |        13 | pref_osdrenderer   | ia44blend |
|              4 |        13 | pref_videorenderer | xvmc-blit |
+----------------+-----------+--------------------+-----------+



xvmc-vld-whitout-xv-blit.log
+----------------+-----------+--------------------+-----------+
| profilegroupid | profileid | value              | data      |
+----------------+-----------+--------------------+-----------+
|              4 |        13 | pref_cmp0          | > 0 0     |
|              4 |        13 | pref_decoder       | xvmc-vld  |
|              4 |        13 | pref_deint0        | none      |
|              4 |        13 | pref_deint1        | none      |
|              4 |        13 | pref_filters       |           |
|              4 |        13 | pref_osdfade       | 0         |
|              4 |        13 | pref_osdrenderer   | ia44blend |
|              4 |        13 | pref_videorenderer | xvmc-blit |
+----------------+-----------+--------------------+-----------+


If you need more information, please ask. Thank you

comment:2 Changed 12 years ago by danielk

Owner: changed from Isaac Richards to danielk

I believe this may be due to changes made to make the VIA CN400 chipset work for HDTV.

1/ In your BIOS how much memory do you have allocated for the video? 2/ Without changing the BIOS settings, does lowering the "5" in this statement

    // need the equivalent of 5 extra surfaces for VLD decoding -- Tegue
    if (surface_has_vld)
        num += 5;

make things work? If so, what is the maximum you can make it while still getting decoding to work?

comment:3 Changed 12 years ago by Robin Gilks <g8ecj@…>

Reducing the value to 4 gets rid of the

(EE) VIA(0): [XvMC] ViaXvMCCreateSurface: Too many surfaces !

errors in Xorg.log for me and also gets rid of the

Unable to create XvMC Surface.

in the frontend log. I've not seen any difference in CPU load or quality on displaying either DVD, DVB-S or IVTV output so not sure if it was a real failure for me (CN400 in an Epia SP13000).

comment:4 in reply to:  2 Changed 12 years ago by anonymous

Replying to danielk:

I believe this may be due to changes made to make the VIA CN400 chipset work for HDTV.

1/ In your BIOS how much memory do you have allocated for the video?

64M

2/ Without changing the BIOS settings, does lowering the "5" in this statement

    // need the equivalent of 5 extra surfaces for VLD decoding -- Tegue
    if (surface_has_vld)
        num += 5;

make things work? If so, what is the maximum you can make it while still getting decoding to work?

Changing it to 4 (like Robin) also got the error to go away. Also, I either mistakenly reported the CPU usage or something else happened, since even BEFORE I made this change, the CPU usage was typical of what I would expect with decoding active, and the display was fine as well. Other than removing the error message, the change down to 4 had no noticable positive or negative effects. Then again, it would appear that the error message itself may have been spurious, since my guess is decoding was working fine anyway.

comment:5 Changed 12 years ago by danielk

Can the original submitter of this bug report reply?

An "Unable to create XvMC Surface" message is normal when VIA XvMC-VLD decoding is working correctly. That is not the problem, the problem is that the reporter apparently did not get XvMC-VLD decoding despite seeing this message.

comment:6 Changed 12 years ago by David Shay <davideshay@…>

I'm the original submitter. Please close this. My first realization is that decoding *must* have been working since my CPU utilization even before the change from 4 to 5 was OK. Somehow, after I setup the profile to force Via XVMC at all resolutions, I saw vastly increased CPU utilization. That led me to check the logs where I saw that error message. After a reboot, the CPU utilization problem is gone, and I guess you are saying the error message is normal (I just don't remember seeing it before). Anyway, all that being said, I guess I'm fine. Sorry for the false alarm.

comment:7 Changed 12 years ago by danielk

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.