Opened 12 years ago

Closed 12 years ago

#4000 closed defect (invalid)

Mythcommflag does not honor max commercial break setting / fails with long commercial breaks

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: commflagging commercial breaks max length
Cc: Ticket locked: no

Description

I've been suffering a weird behaviour of mythcommflag. It does a great job detecting short commercial breaks (not longer than 6 minutes) but it always fails whenever the commercial break exceeds 6:30 minutes (aprox.).

Here in Spain, broadcasters tend to insert looooong commercial breaks, sometimes longer than 15 minutes. I've read in ticket 880 (http://svn.mythtv.org/trac/ticket/880) that there is a max commercial skip of 3600 secs, that is, 1 hour. I've set that value to 1200 (20 min) in the preferences pages in mythfrontend. This is a fair value, even for Spain broadcasters.

However, when there is a "long" commercial break, mythcommflag only includes in the cutlist the first 6:30 minutes, even though it almost never fails when the break is short. This behaviour happens with all the different commflagging methods, experimental included.

I am using 14520 SVN version, but this has been happening for all the time I've known MythTV (which is more than 10 months).

Thank you in advance

Change History (1)

comment:1 Changed 12 years ago by cpinkham

Resolution: invalid
Status: newclosed

This is not a defect, it is by design to prevent false positives in areas where most commercial breaks are less than 7 minutes. There is an undocumented setting that you can insert into your database to allow longer breaks to be detected. The setting is CommDetectMaxCommBreakLength? and defaults to 395 seconds (6 minutes, 35 seconds). You can bump this up to 15 minutes and 10 seconds by inserting a new row into your settings table by running an SQL command similar to the following. There is no way to edit this value through the GUI.

insert settings ( value, data, hostname ) values ( 'CommDetectMaxCommBreakLength?', 910, NULL);

Next time please ask first on the mailing list (and don't reply on this ticket, trac isn't for discussion).

Note: See TracTickets for help on using tickets.