Opened 12 years ago

Closed 12 years ago

#4001 closed defect (duplicate)

Mythtv audio and Dvico FusionHDTV5 RT Gold

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: unknown
Severity: medium Keywords: audio dvico fusionHDTV
Cc: Ticket locked: no

Description

Capture Card: Dvico FusionHDTV5 RT Gold
Motherboard: Abit AB9 Quad GT
CPU: Intel 2.4GHz Quad-core
Distribution: Ubunutu 7.04 64-bit
Audio device: /dev/dsp
Video device: /dev/video0
Using as an anolog device.
mythtv version: 0.20.2 (proposed ubuntu 7.04 package)

Description: I have the audio from the capture card plugged in to the cd-in on the motherboard. Using TvTime? or XawTV, I have no problems with audio and video. Using mythtv, I have two situations when changing options on alsamixer:

  1. Set cd-in mute and capture I get no audio using mythtv. Recorded shows have no audio.
  2. Set cd-in unmute and capture, I get no audio using mythtv until I change the channel. After changing the channel, the audio is 7-8 seconds out of sync. Trying to sync using 'm' key will not work. Additionally, video becomes laggy on my quad-core/8GB RAM/Raptor HD computer. Eventually, mythtv reports an error with the video.

Best Guess: the audio is not being caputured properly by mythtv during situation #1. This is the correct configuration for alsa as described by the mythtv help on audio found here http://www.mythtv.org/docs/mythtv-HOWTO-7.html.

Some relevant output:

amixer
Simple mixer control 'Headphone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 0 [0%] [-51.00dB]
  Front Right: Playback 0 [0%] [-51.00dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 22 [71%] [-13.50dB] [on]
  Front Right: Playback 22 [71%] [-13.50dB] [on]
Simple mixer control 'Front Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 17 [55%] [-21.00dB] [off]
  Front Right: Playback 17 [55%] [-21.00dB] [off]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 12 [39%] [-28.50dB] [on]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 11 [35%] [-30.00dB] [on]
Simple mixer control 'Side',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 11 [35%] [-30.00dB] [on]
  Front Right: Playback 11 [35%] [-30.00dB] [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 23 [74%] [0.00dB] [off]
  Front Right: Playback 23 [74%] [0.00dB] [off]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined cswitch cswitch-joined
  Playback channels: Mono
  Capture channels: Mono
  Mono: Playback [off] Capture [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 24 [77%] [19.50dB] [on]
  Front Right: Capture 24 [77%] [19.50dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 24 [77%] [19.50dB] [on]
  Front Right: Capture 24 [77%] [19.50dB] [on]
Simple mixer control 'Input Source',0
  Capabilities: enum
  Items: 'Mic' 'Front Mic' 'Line' 'CD'
  Item0: 'CD'
Simple mixer control 'Input Source',1
  Capabilities: enum
  Items: 'Mic' 'Front Mic' 'Line' 'CD'
  Item0: 'CD'

Change History (2)

comment:1 Changed 12 years ago by nilshomer@…

I apologize for the double ticket (4001 and 4002),

Nils Homer nilshomer@…

comment:2 Changed 12 years ago by greg

Resolution: duplicate
Status: newclosed

Closing, duplicate of #4002

Note: See TracTickets for help on using tickets.