Opened 12 years ago

Closed 12 years ago

#4008 closed defect (invalid)

SVN 14526 - Compile error with XvMC

Reported by: skd5aner@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Just updated to latest SVN - 14562. I'm getting an error when I'm trying to compile (with lXvMCNVIDIA, which is normal for me):

make[2]: Entering directory `/usr/src/mythtv/mythtv/programs/mythtv'
ccache g++ -c -pipe -march=k8 -I/usr/include/kde/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -Wall -W -fomit-frame-pointer -O3 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -D__STDC_CONSTANT_MACROS -fomit-frame-pointer -D_REENTRANT  -DMMX -Di386 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr/local\" -DLIBDIR=\"/usr/local/lib\" -DUSING_X11 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I../../../../../local/include -I../../../../../include -I../.. -I../../libs -I../../libs/libmyth -I../../libs/libmythtv -I../../libs/libavutil -I../../libs/libavformat -I../../libs/libavcodec -I../../libs/libmythupnp -I../../libs/libmythui -I../../libs/libmythlivemedia -I../../../../../include/qt3 -I/usr/X11R6/include -I/usr/X11R6/include -o main.o main.cpp
ccache g++  -o mythtv main.o    -L/usr/share/qt3/lib -L../../libs/libmyth -L../../libs/libmythtv -L../../libs/libavutil -L../../libs/libavcodec -L../../libs/libavformat -L../../libs/libmythfreemheg -L../../libs/libmythui -L../../libs/libmythupnp -L../../libs/libmythlivemedia -lmythtv-0.20 -lmythavformat-0.20 -lmythavutil-0.20 -lmythavcodec-0.20 -lmythfreemheg-0.20 -lmythupnp-0.20 -lmythlivemedia-0.20 -lmyth-0.20 -lmythui-0.20 -lfreetype -lz -lmp3lame -lasound -L/usr/lib -lartsc -lgmodule-2.0 -ldl -lgthread-2.0 -lrt -lglib-2.0 -ljack -lraw1394 -liec61883 -lavc1394 -lrom1394 -L/usr/X11R6/lib -lXinerama -lXv -lXxf86vm -lXrandr -lXvMCNVIDIA -lXvMC -lqt-mt -lGLU -lGL -lXmu -lXext -lX11 -lm -lpthread
../../libs/libmythtv/libmythtv-0.20.so: undefined reference to `XvMCPutSlice2'
collect2: ld returned 1 exit status
make[2]: *** [mythtv] Error 1
make[2]: Leaving directory `/usr/src/mythtv/mythtv/programs/mythtv'
make[1]: *** [sub-mythtv] Error 2
make[1]: Leaving directory `/usr/src/mythtv/mythtv/programs'
make: *** [sub-programs] Error 2

Change History (3)

comment:1 Changed 12 years ago by danielk

Owner: changed from Isaac Richards to danielk

I can't reproduce this. What are your ./configure params and are you using trunk or the 0.20-fixes branch?

The compile error you have here indicates that VLD is enabled even though you are linking to the nVidia XvMC library.

comment:2 Changed 12 years ago by skd5aner@…

Please disregard and close ticket as invalid. All is well with trunk. It was an error on my part when trying to force configure to autodetect the nVidia XvMC libraries, I didn't make the proper changes - copy and paste error. Sorry for the noise. Thanks Daniel for looking into this ticket so quickly.

comment:3 Changed 12 years ago by danielk

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.