Opened 12 years ago

Closed 12 years ago

#4018 closed defect (invalid)

mythcommflag reports 0 commercial breaks in log even when it finds commercial breaks

Reported by: anonymous Owned by: cpinkham
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When looking at the mythbackend log, every commercial break run reports 0 commercial breaks. However, when watching the show, commercials are in fact flagged.

2007-09-26 04:18:42.188 commflag: Commercial Flagging Finished: Robot Chicken "The Black Cherry" recorded from channel 1052 at Wed Sep 26 00:10:00 2007 (0 commercial break(s))

Attachments (2)

ticket4018_1.log (34.2 KB) - added by anonymous 12 years ago.
commflag.patch (911 bytes) - added by anonymous 12 years ago.
Patch to count commercials in loop

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by cpinkham

Resolution: invalid
Status: newclosed

I get the feeling that you have editted the "Commercial Flagger command" setting and this is somehow related. Please ask about this on the mailing lists as this is working fine for literally thousands of people. Marking ticket as invalid for now.

comment:2 Changed 12 years ago by rbonafied@…

Resolution: invalid
Status: closedreopened

I double checked the mythtv-setup and confirmed the mythcommflag command was blank. I then restarted the backend. The log still reports 0 commercial break even though they are there.

The commflag method is set to 'experimental'

comment:3 Changed 12 years ago by cpinkham

Owner: changed from Isaac Richards to cpinkham
Status: reopenednew

I'm not a dentist, I don't pull teeth. You're going to have to help a little if you want this issue solved. How about providing some backend logs with Commercial Flagging and JobQueue? debugging turned on (ie, "mythbackend -v commflag,jobqueue". That might help a little.

Changed 12 years ago by anonymous

Attachment: ticket4018_1.log added

comment:4 Changed 12 years ago by anonymous

As you wish... a job was recorded and the backend log is attached with the '-v commflag,jobqueue' settings active. See attachment: ticket4018_1.log

comment:5 Changed 12 years ago by anonymous

I have done some investigation into this ticket and the only way I can see this happening is if the commercial flagging is done via the looping construct which does not count the number of commercials flagged. I have created a patch that does count the number in this situation and attached it. I don't think it should have any adverse effects.

Changed 12 years ago by anonymous

Attachment: commflag.patch added

Patch to count commercials in loop

comment:6 Changed 12 years ago by rbonafied

Since upgrading my OS to Mandriva 2008 and recompiling, I haven't been able to reproduce the issue I experienced in Mandriva 2007.1 . I guess it's a non-issue at this point.

comment:7 Changed 12 years ago by cpinkham

Resolution: invalid
Status: newclosed

Closing ticket per comments from user. mythcommflag isn't meant to be run on all recordings in one shot by the JobQueue?, the JobQueue? is only expecting to flag one program, so I don't think the patch attached to the ticket is relevant.

Note: See TracTickets for help on using tickets.